PI admin showing spinning wheel


#5

Yeah, looking at your debug log, it seems your log file was larger than 270MB. Is this something you’d expect (like many many clients, etc.)?


#6

It was 271 MB. I do not expect that at all. I am now running pihole alone, not as DHCP server.
My router (Netgear R7800) has imited DHCP options, i can only set DNS in the WAN settings.
But i use my router as DHCP now. Before i used the PI.

Screenshots for illustration:

afbeelding

Both in both cases it returned the spinning wheel. Why does the log file not shrink or compress or rotate?
What can i do to fix this?


#7

The log file does rotate and compress. However, you have many hundreds of thousands of queries on your network within 24 hours, and that data needs to be stored somewhere. You have one or more clients (hiding behind your router) who are making a lot of queries.


#8

So how do i figure out which it is?


#9

Check the queries, see if anything identifies it (amazon device making queries to amazon). It looks like you have devices already pointed to Pi-hole instead of the router, so it might also be the router making a ton of queries.


#10

One way is to turn off all the devices connected to your router that aren’t shown as individual IP addresses (those are tracked individually by the PiHole as shown on your screen shot). Then tail the pihole log, and turn devices on one at a time. You’ll soon find the chatty one. I have found that IOT devices tend to do a lot of network queries (phoning home, checking network status, metrics, etc.),


#11

Okay. I will check them out.
Why are still clients in this list of clients of DHCP?
I set the DHCP to my R7800 router more than a day ago!

Ok. i reset the stats using this: How can i reset all pihole stats?

Now it looks like this after an hour:


#12

Again this morning same log file size (271MB). What can I do?
In pohole.log is see a lot of this:

Jun 10 00:00:55 dnsmasq[23983]: 124090 192.168.1.1/50030 cached wvkreg.stackstorage.com is 37.97.197.4
Jun 10 00:21:30 dnsmasq[23983]: 131460 192.168.1.1/50030 cached wvkreg.stackstorage.com is 37.97.197.2
Jun 10 00:21:30 dnsmasq[23983]: 131460 192.168.1.1/50030 cached wvkreg.stackstorage.com is 37.97.197.3
Jun 10 00:21:30 dnsmasq[23983]: 131460 192.168.1.1/50030 cached wvkreg.stackstorage.com is 37.97.197.1
Jun 10 00:21:30 dnsmasq[23983]: 131460 192.168.1.1/50030 cached wvkreg.stackstorage.com is 37.97.197.6
Jun 10 00:21:30 dnsmasq[23983]: 131460 192.168.1.1/50030 cached wvkreg.stackstorage.com is 37.97.197.4
Jun 10 00:21:30 dnsmasq[23983]: 131460 192.168.1.1/50030 cached wvkreg.stackstorage.com is 37.97.197.5
Jun 10 00:21:30 dnsmasq[23983]: 131461 192.168.1.1/50030 query[AAAA] wvkreg.stackstorage.com from 192.168.1.1
Jun 10 00:21:30 dnsmasq[23983]: 131461 192.168.1.1/50030 cached wvkreg.stackstorage.com is 2a01:7c8:fe11:179::2
Jun 10 00:21:30 dnsmasq[23983]: 131461 192.168.1.1/50030 cached wvkreg.stackstorage.com is 2a01:7c8:fe11:179::3
Jun 10 00:21:30 dnsmasq[23983]: 131461 192.168.1.1/50030 cached wvkreg.stackstorage.com is 2a01:7c8:fe11:179::4
Jun 10 00:21:30 dnsmasq[23983]: 131461 192.168.1.1/50030 cached wvkreg.stackstorage.com is 2a01:7c8:fe11:179::6
Jun 10 00:21:30 dnsmasq[23983]: 131461 192.168.1.1/50030 cached wvkreg.stackstorage.com is 2a01:7c8:fe11:179::5
Jun 10 00:21:30 dnsmasq[23983]: 131461 192.168.1.1/50030 cached wvkreg.stackstorage.com is 2a01:7c8:fe11:179::1
Jun 10 00:21:30 dnsmasq[23983]: 131462 192.168.1.1/50030 query[A] wvkreg.stackstorage.com from 192.168.1.1
Jun 10 00:21:30 dnsmasq[23983]: 131462 192.168.1.1/50030 cached wvkreg.stackstorage.com is 37.97.197.5
Jun 10 00:21:30 dnsmasq[23983]: 131462 192.168.1.1/50030 cached wvkreg.stackstorage.com is 37.97.197.2
Jun 10 00:21:30 dnsmasq[23983]: 131462 192.168.1.1/50030 cached wvkreg.stackstorage.com is 37.97.197.3

Some lines later:

Jun 10 00:21:30 dnsmasq[23983]: 131463 192.168.1.1/50030 query[AAAA] wvkreg.stackstorage.com from 192.168.1.1

Why does it query so much?


#13

Many routers ping out constantly to check your internet connectivity.

Change your router’s dns AWAY from your pi-hole.

It should not be set to anything on your local network. Set it to 8.8.8.8 or any other dns of your choice.

You can use Pi-hole as your DHCP and then only devices on your network (and not your router) will be querying it, and the log file will not get so out of hand.


#14

Okay, thanks. But if I change the DNS in the router all my clients will also start to use OpenDNS and they will bypass the pihole. I do not see the use of the Pihole then. I dont want to configure all my clients manually and i cant change DHCP options on the router to set DNS. There is no option to set it up (netgear r7800)


#15

Are you sure there is no setting like WAN DNS? If not, then you can disable DHCP on the router and enable it on the Pi-hole.


#16

See this topic above for my settings on router. There is one dns setting in the router which i can set on manual or automatic.


#17

Then try using Pi-hole for DHCP.


#18

@wvkreg Your router does not support setting a LAN dns. Set your Router’s DNS away from your Pi-hole, or it will keep hammering it with requests. You will need to disable DHCP on your router before your Pi-hole can serve as the DHCP server.

To disable DHCP on your router :

On the basic homepage:
Select ADVANCED > Setup > LAN Setup .
Clear the Use Router as DHCP Server check box. & Click the Apply button.

This will set ONLY your router to use the external DNS address (once you set your Pi-hole as your DHCP server, your devices will use your Pi-hole for their DNS queries):

On the basic homepage
Select Internet, Scroll down to Domain Name Server (DNS) and click Get Dynamically from ISP & Click the Apply Button.

To set your pihole as your active DHCP server, follow these directions.


#19

Ok all good and i understand.
But then how is the PI my dns server since i set the router to Opendns?
Is it so that if i set the PI as DHCP that i will automatically catch dns queries?


#20

When you use Pi-hole as DHCP server it will explicitly tell all clients to use it as DNS server. Your router has no influence on this setting on the client’s as the DHCP server is responsible for the entire network configuration. The router will only be used as a gateway to the Internet but nothing more.


#21

Ok ill try


#22

Till now it looks ok.


#23

Update: all ok now. https://wvkreg.stackstorage.com was the issue i guess. It is a sort of Dropbox cloud storage


#24

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.