Php7.3-fpm and lighttpd failing after updating pihole

Expected Behaviour:

After logging in to the web console I saw an update was available so I proceeded to ssh to the instance, pihole -up followed by failures resulting from the two dependencies mentioned above.

Users expect updates to work with zero extra problems, not break components of the system. Otherwise, the upgrade should gracefully fail.

Actual Behaviour:

php7.3-fpm and lighttpd services both show failed state and admin UI is down as a result.

 lighttpd[644]: /usr/sbin/lighttpd: symbol lookup error: /usr/lib/arm-linux-gnueabihf/ undefined symbol: VAL_CTX_new, version OPENSSL_1_1_0

Debug Token:

Have you run any kind of apt update previously? The error references a library we don’t use or include as a dependency.

Hi Dan,

No I have not.

Can you do a sudo apt update and check if there are any packages that are in need of updating?

performed sudo apt update, which reported packages available for upgrade so I upgraded. now I am asked if i’d like to replace a modified php.ini file with an updated one from the updated package:

     │ A new version (/usr/lib/php/7.3/php.ini-production) of configuration file /etc/php/7.3/fpm/php.ini is available, but the version installed currently has been locally modified.  │
     │                                                                                                                                                                                  │
     │ What do you want to do about modified configuration file php.ini?                                                                                                                │

What do you suggest?

I don’t see the fpm module in my local php 7.3 install for Pi-hole. If you can do a diff of the files so you can see what is being changed then you will be able to check if the file needs to be kept or if the new version can be accepted.

tried updating with the new config file and no change. Both services fail to start.

What is the message from sudo systemctl status --full --no-pager lighttpd.service?

Hold on , almost the same :wink:

Could be config files.

This time though it doesn’t appear to be a library issue.

Try manually running sudo /usr/sbin/lighttpd -tt -f /etc/lighttpd/lighttpd.conf and check for the error output.

1 Like
/usr/sbin/lighttpd: symbol lookup error: /usr/lib/arm-linux-gnueabihf/ undefined symbol: VAL_CTX_new, version OPENSSL_1_1_0

I don’t know why it’s asking about SSL or crypto since everything on the web interface is non-encrypted. Tried a google search on that error message and didn’t get any kind of useful information.

pi@noads:~ $ dpkg -S /usr/lib/arm-linux-gnueabihf/
libssl1.1:armhf: /usr/lib/arm-linux-gnueabihf/

pi@noads:~ $ apt rdepends libssl1.1
Reverse Depends:
  Depends: php7.0-fpm (>= 1.1.0)
  Depends: php7.0-common (>= 1.1.0)
  Depends: php7.0-cli (>= 1.1.0)
  Depends: php7.0-cgi (>= 1.1.0)
  Depends: lighttpd (>= 1.1.0)

Could try purge all of them including config files:

sudo dpkg -P libssl1.1 php7.3-fpm php7.3-common php7.3-cli php7.3-cgi lighttpd

And reinstall from apt cache so the config files are defaulted:

sudo apt install --reinstall libssl1.1 php7.3-fpm php7.3-common php7.3-cli php7.3-cgi lighttpd

But be warned that there is a slight risk this might break something like alterations done by DietPi!
And maybe you have to reconfigure lighttpd and tell it to use the fpm daemon instead of the default php-cgi binary to interpret PHP for lighttpd.
And let Pi-hole make necessary alterations to lighttpd config by selecting repair:

pihole -r


Thanks for this suggestion, it helped me resolve the problem and now the admin UI works as expected. The only step that did not work from your post was sudo dpkg -p ..... This failed with dependency problems - not removing error messages for each package you suggested to remove.

Despite that, reinstalling the packages and then repairing pi-hole resulted in success.

Thanks again for your help and also to @DanSchaper for your help troubleshooting and for working on the project. :+1:


This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.