PC not connecting to Pi-Hole, but phone works fine

Expected Behavior:
My PC's DNS should be connecting to the ip of the pi-hole ( and working just like my phone is.

Actual Behavior:
My PC does not block any ads, and when I log into the admin page of the pi-hole, It says that my PC's ip address is connected, but not queries are happening, therefore no queries are blocked.

I Configured my pi-hole to have a static ip address at (, and phones on the network work fantastic, I just have to manually change their dns to the ip address of the pi-hole.

I looked into setting up the pi-hole as my dns in my router, but since I am using the xfinity gateway router, I have found that you cannot change the DNS of it.

Any help appreciated!

Debug Token:

If your PC's DNS requests are not showing up in Pi-hole's Query Log, that would indicate that your browser or your PC is using n alternate DNS resolver.

You should verify that DoH is not active in your browser, but also, your debug log shows your Pi-hole to have public IPv6 connectivity, and your Pi-hole host is using a pair of IPv6 DNS addresses for DNS:

-rw-r--r-- 1 root root 121 May 20 00:40 /etc/resolv.conf
   nameserver 2001:558:feed::1
   nameserver 2001:558:feed::2

As those do not match any of your Pi-hole's IPv6 addresses, it is likely that your router is advertising those IPv6 address as DNS server, allowing your clients to by-pass Pi-hole.

You'd have to find a way to configure your router to advertise your Pi-hole host machine's IPv6 as DNS server or to stop advertising alternatives.

You'd have to consult your router's documentation sources on further details for its IPv6 configuration options.

If your router doesn't support configuring IPv6 DNS, you could consider disabling IPv6 altogether.

If your router doesn't support that either, your clients will always be able to bypass Pi-hole via IPv6.

I disabled IPv6 and it fixed it.

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.