OpenWRT ipv6 address

Hi,

I’ve got an OpenWRT router, and I’ve configured it to send to DHCP clients the ip of the pihole for DNS servers. I did that by following the guide on https://forum.openwrt.org/t/pihole-dns-configurat-with-openwrt/33477/2, which I did with:

network > interfaces > lan > dhcp server > advanced settings > dhcp-options

Type 6,address of pihole

That works, except for ipv6. It seems my router is giving me an ipv6 nameserver, which is the router itself:

nameserver 192.168.1.241
nameserver fd34:85d2:7e25::1

The first one is my pihole, but the second is my openwrt! How do I fix that?

That is an issue with OpenWRT configuration, not with Pi-hole.

You’d have better chances for an answer if you post that in their forums. :wink:

If this hasn’t been answered on their forum, try changing the value for interfaces > LAN > DHCP Server > IPv6 Settings > Save/Commit

If on Windows ipconfig /release6 & ipconfig /renew6.