OpenDns isnt working

Please follow the below template, it will help us to help you!

If you are Experiencing issues with a Pi-hole install that has non-standard elements (e.g you are using nginx instead of lighttpd, or there is some other aspect of your install that is customised) - please use the Community Help category.

Expected Behaviour:

Pi 2 B
Pi-Hole 5.1.1
Choosing Open DNS as Upstream DNS Servers should block ads and adult sites

Actual Behaviour:

Choosing Open DNS as Upstream DNS Servers is not block ing ads and adult sites where as using CleanBrowsing or Cloudfare works fine.

I want to use Open DNS as I want to use the VPN / Proxy block option.

Debug Token:

https://tricorder.pi-hole.net/p4dpbb7tiu

Run from a CLI or Terminal window on your Pi-hole machine, what's the output of:

echo ">stats >quit" | nc localhost 4711

with Open DNS or or different DNS?

The command will list stats for the last 24 hours.
It won't influence the overall results much if you switch DNS servers just now.
It would help to know which DNS servers you've used during that time, though.

echo ">stats >quit" | nc localhost 4711
domains_being_blocked 85314
dns_queries_today 50523
ads_blocked_today 23022
ads_percentage_today 45.567364
unique_domains 3509
queries_forwarded 22988
queries_cached 4498
clients_ever_seen 17
unique_clients 15
dns_queries_all_types 50523
reply_NODATA 1079
reply_NXDOMAIN 469
reply_CNAME 3921
reply_IP 10383
privacy_level 0
status enabled

That shows your Pi-hole has blocked roughly 45% of your DNS queries for the last 24 hours, and it also shows its current blocking status as enabled.

Pi-hole's blocking is not related to your choice of upstream DNS server in any way. Pi-hole will block the same domains, no matter what upstream DNS you pick.

If you are still seeing ads or other unwanted content, you'd have to find out what domain is serving them:

the thing is that - when I had Open DNS enabled i could search for adult images in google and could see all the explicit search results and could visit adult video sites.

i enabled a different DNS provider and all of them got disabled.

An upstream DNS server may employ its own filtering rules, after and in addition to Pi-hole's filtering.
Your observaton would indicate that one of your other upstream DNS servers does so.

thanks [Bucking_Horn]. I will do more testing then.

Would you be able to tell me if I can do the following in Pi Hole?

ALLOW TCP/UDP IN/OUT to 208.67.222.222 or 208.67.220.220 on Port 53

and

BLOCK TCP/UDP IN/OUT all IP addresses on Port 53

You can't.
Pi-hole is a filtering DNS forwarder.

Those lines of yours look like firewall options.
If they are meant to block the DNS port 53 for your network, they should be applied at router / gateway level. You want to make sure you still allow access for Pi-hole, though. Your current lines do not seem to do so.