Only router IP/hostname showing on dashboard

Expected Behaviour:

Different clients showing up on dhasboard

Actual Behaviour:

Only router hostname showing up

Debug Token:

I've read about this and tried editing /etc/hosts file with all clients IP addresses (making sure they're fixed). DNS is set at router level and I have no way of disabling the router's DHCP server to set pihole as the DHCP server.

Any help would be appreciated.

Thanks, I did read the FAQ.
So even editing the hosts file on the pi, the router still might be forcing a DNS and the PI is only seen as an upstream DNS?
Well that's a bummer...

If you can't set the DNS server distributed by your router via DHCP you could try the following: Limit the DHCP range to a single address - the one for your Pi-hole device. Then enable Pi-holes DHCP server wich will serve all other clients on the network.

1 Like

That's an interesting suggestion!! Will try that later and report back :slight_smile:

This seems to have worked, I can see all different clients showing up and they're all complying with /etc/hosts. I have also assigned them static ips under the DHCP setup.

Is it normal to still see average traffic coming from my router, given all devices now are being assigned by the pi?

Thanks in advance

Did all of your devices acquire a DHCP lease through Pi-hole yet?

DHCP leases are handed out with a certain lifetime. Clients won't request a new DHCP lease before the current one is about to expire, so some of them might still be using your router for DNS.

If you don't want to wait this out, you have to force each client to renew its DHCP lease, e.g. by switching wifi off and on with a smartphone or by power-cycling a PC. or IoT device.

1 Like

I see 13 leases and have assigned 13 fixed ips. Might have to wait for stragglers so will check tomorrow :slight_smile:
Thanks again!

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.