Only my router is using Pi-hole

Expected Behaviour:

I expect to see all my devices using pihole to be listed on my network panel on the admin website.

Actual Behaviour:

All I see is requests made by my router and not other devices. Other devices are listed but have IPv6 numbers and have not made any requests. Also in the debug log I noticed that I can't ping my default gateway. It does seem like pihole is working just maybe all requests are going through to my router before pihole? I'm using a router provided by Starry which has minimal options and there isn't much info about it.

Debug Token:

This works like expected if you have the the pihole as your Routers DNS and the Clients are using the Router as their DNS

Therefore you have to distribute pihole's IP as DNS server via DHCP. This has to be configured at your router. Once you did, you have to de/reconnect your clients to the network to pickup the new settings.

This indicates a network configuration erorr.

Depending on what kind of IPv6 addresses that are your router might assign global IPv6 addresss to your devices. They could use them to circumvent pihole and query another DNS server. Do you need IPv6? If not, turn it of in your router or use ULA

So the weird thing is that I don't have IPv6 available on my router. My setup is: ISP Router [Starry] (which I can't change because any other router won't work.) > [TP-Link Deco S4 Mesh Wifi] Routers running in bridge mode. All my devices have static IPv4 addresses. I have disconnected and reconnected clients/rebooted my router and still no change.

Also when I run dig I get my main router's IP as the DNS server running through port 53.


; <<>> DiG 9.10.6 <<>>
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 50450
;; flags: qr rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 0, ADDITIONAL: 1

; EDNS: version: 0, flags:; udp: 512
;			IN	A


;; Query time: 23 msec
;; WHEN: Sat Jun 20 05:59:16 PDT 2020
;; MSG SIZE  rcvd: 55

Well after much searching and fooling around I think what is happening is that my router is taking all the requests from my devices and sending them to PiHole. This causes PiHole to display only my routers IP in the network tab of the admin panel. So PiHole is working but I can’t get an accurate picture of what devices are doing what. Hope this helps someone out, thanks for all the help.

Maybe it would be helpful if you let us know the brand and model of your router. So others with the same model might find this topic and see that the router intercepts DNS traffic.

Sure! It’s the Starry Launch Router.

1 Like

Would it be an option to disable DHCP on this router and use pihole's DHCP server?

No you can't and its proprietary to the ISP. The only way to get around would be to use a second router but then you run into double nat and etc.

Can you at least modify the DHCP range on the router? You could limit it to one address (and make a static assignment to the device hosting pihole) and than turn on pihole's DHCP for all other devices.

Yeah that could work!

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.