Not working with Windows 10

I have Pi hole set up and it works great on all my devices except for my Windows 10 machine. I’m using pihole to serve DHCP if that matters. Things will be fine on my Windows 10 machine. Then if I close it and come back later. It can’t connect to the internet. It keeps telling me there’s a DNS error. I can usually get rid of this by rebooting pihole or flushing the DNS cache. The strange thing is that even if I disable pihole, the problem persists. Eventually with some futzing I can get it working again. But like I said it works perfectly on all my other devices, including iOS Android and OSX. Thanks

Run below one in a command prompt on your Windows station to check network details (DNS server, DHCP server):

ipconfig /all

Did you disable the router DHCP service ?

What is the error displayed ?

Is flushing DNS cache sufficient or do you really need to reboot Pi-hole as well ?

What problem ? The same DNS error ?

A good test is to open below link in a browser.
If it doesnt redirect you to the Pi-hole admin page, the PC/system/device is not using Pi-hole for DNS resolution:

http://pi.hole

Ps. what browser are you using on the Windows station ?

Thanks for the help! The problem appears to be a bit intermittent. Just now things weren’t working but as I was trying to copy the “DNS” error I was getting in the browser, it suddenly reconnected. I also discovered that I’m having the same issue on my mac laptop.

The ipconfig /all yields
Windows IP Configuration

   Host Name . . . . . . . . . . . . : ENG-03793
   Primary Dns Suffix  . . . . . . . :
   Node Type . . . . . . . . . . . . : Hybrid
   IP Routing Enabled. . . . . . . . : No
   WINS Proxy Enabled. . . . . . . . : No
   DNS Suffix Search List. . . . . . : local

Ethernet adapter Ethernet:

   Media State . . . . . . . . . . . : Media disconnected
   Connection-specific DNS Suffix  . :
   Description . . . . . . . . . . . : Intel(R) Ethernet Connection I219-LM
   Physical Address. . . . . . . . . : 54-EE-75-B7-05-3A
   DHCP Enabled. . . . . . . . . . . : Yes
   Autoconfiguration Enabled . . . . : Yes

Wireless LAN adapter Local Area Connection* 2:

   Media State . . . . . . . . . . . : Media disconnected
   Connection-specific DNS Suffix  . :
   Description . . . . . . . . . . . : Microsoft Wi-Fi Direct Virtual Adapter
   Physical Address. . . . . . . . . : F0-D5-BF-62-7E-A7
   DHCP Enabled. . . . . . . . . . . : Yes
   Autoconfiguration Enabled . . . . : Yes

Wireless LAN adapter Wi-Fi:

   Connection-specific DNS Suffix  . : local
   Description . . . . . . . . . . . : Intel(R) Dual Band Wireless-AC 8260
   Physical Address. . . . . . . . . : F0-D5-BF-62-7E-A6
   DHCP Enabled. . . . . . . . . . . : Yes
   Autoconfiguration Enabled . . . . : Yes
   Link-local IPv6 Address . . . . . : fe80::183b:9e60:ed08:23cb%12(Preferred)
   IPv4 Address. . . . . . . . . . . : 192.168.1.245(Preferred)
   Subnet Mask . . . . . . . . . . . : 255.255.255.0
   Lease Obtained. . . . . . . . . . : Friday, July 21, 2017 12:49:05 PM
   Lease Expires . . . . . . . . . . : Saturday, July 22, 2017 12:49:41 PM
   Default Gateway . . . . . . . . . : 192.168.1.1
   DHCP Server . . . . . . . . . . . : 192.168.1.250
   DHCPv6 IAID . . . . . . . . . . . : 250664383
   DHCPv6 Client DUID. . . . . . . . : 00-01-00-01-20-0A-64-34-54-EE-75-B7-05-3A
   DNS Servers . . . . . . . . . . . : 192.168.1.250
   NetBIOS over Tcpip. . . . . . . . : Enabled

Ethernet adapter Bluetooth Network Connection:

   Media State . . . . . . . . . . . : Media disconnected
   Connection-specific DNS Suffix  . :
   Description . . . . . . . . . . . : Bluetooth Device (Personal Area Network)
   Physical Address. . . . . . . . . : F0-D5-BF-62-7E-AA
   DHCP Enabled. . . . . . . . . . . : Yes
   Autoconfiguration Enabled . . . . : Yes

Tunnel adapter Local Area Connection* 13:

   Connection-specific DNS Suffix  . :
   Description . . . . . . . . . . . : Microsoft Teredo Tunneling Adapter
   Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
   DHCP Enabled. . . . . . . . . . . : No
   Autoconfiguration Enabled . . . . : Yes
   IPv6 Address. . . . . . . . . . . : 2001:0:9d38:953c:28ca:3bad:3f57:fe0a(Preferred)
   Link-local IPv6 Address . . . . . : fe80::28ca:3bad:3f57:fe0a%17(Preferred)
   Default Gateway . . . . . . . . . : ::
   DHCPv6 IAID . . . . . . . . . . . : 285212672
   DHCPv6 Client DUID. . . . . . . . : 00-01-00-01-20-0A-64-34-54-EE-75-B7-05-3A
   NetBIOS over Tcpip. . . . . . . . : Disabled

Tunnel adapter isatap.local:

   Media State . . . . . . . . . . . : Media disconnected
   Connection-specific DNS Suffix  . : local
   Description . . . . . . . . . . . : Microsoft ISATAP Adapter
   Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
   DHCP Enabled. . . . . . . . . . . : No
   Autoconfiguration Enabled . . . . : Yes

The error its giving is a DNS not found sort of error. I was trying to copy it exactly but it started working again and the error disappeared.

Yes, I’ve turned of DHCP on my router.

These errors are all on Chrome (osx and windows 10)

Thanks

The specific error is DNS probe finished bad config.
Flushing DNS doesn’t seem to help on my PC.

Did you enable IPv6 support in the Pi-hole DHCP settings ?
Try disabling it and reboot the PC (or release/renew the DHCP lease).

Googling(DuckDuck) a bit, this doesnt appear to be a Pi-hole related error but I cant find any properly documented explanation for this error.

@EDIT
I solved the issue. I was using WiFi previously but I connected through ethernet cable and everything works good. I think it would be a good idea to add this to a FAQ.


I think I have a similar issue. What router are you using?

  • Huawei HG658c router
  • Raspberry PI with clean Raspbian OS install

I have reserved IP address for my Raspberry PI, it’s also out of the DHCP range just in case
Pi-Hole works on my Raspberry Pi. Web interace works, queries are blocked etc.
Using router’s DHCP I’m getting a DNS bad config error on all my other machines (Win 10)
Setting preferred DNS on my Win 10 machine results in the same.

With router’s DHCP off and Pi-Hole’s DHCP on, I was getting no internet connection whatsoever, couldn’t even connect to my router after flushing DNS

sudo service pihole-FTL status
● pihole-FTL.service - LSB: pihole-FTL daemon
Loaded: loaded (/etc/init.d/pihole-FTL)
Active: active (exited) since Sun 2017-08-13 16:17:15 UTC; 1 day 3h ago
Process: 496 ExecStart=/etc/init.d/pihole-FTL start (code=exited, status=0/SUCCESS)

Aug 13 16:17:14 raspberrypi pihole-FTL[496]: Not running
Aug 13 16:17:14 raspberrypi su[553]: Successful su for pihole by root
Aug 13 16:17:14 raspberrypi su[553]: + ??? root:pihole
Aug 13 16:17:14 raspberrypi su[553]: pam_unix(su:session): session opened for user pihole by (uid=0)
Aug 13 16:17:14 raspberrypi pihole-FTL[496]: FTL started!
Aug 13 16:17:15 raspberrypi systemd[1]: Started LSB: pihole-FTL daemon.

For people who find this no 1 post via Google and are still left in the dark. Windows 10 only accepts DNS over HTTPS (mind the S). So a regular install of PiHole doesn’t work. The fix is found here: https://docs.pi-hole.net/guides/dns-over-https/

So basically you will need to add support DNS-over-HTTPS and use a custom upstream DNS.

I don’t believe that’s accurate. Certainly not for me?

Here’s a background article on Windows 10: https://nakedsecurity.sophos.com/2019/11/21/dns-over-https-is-coming-to-windows-10/ Setting up DNS-over-https did the trick for me. After much frustration and a couple of reinstalls of PiHole on different hardware. So maybe it is just luck… but maybe it helps someone else.

Thanks for the link. I think that just outlines some future plans and doesn’t deprecate DNS over 53, at least I have not seen that on any systems I manage. But good to have an additional data point or item to check for debugging.

I have a similar issue on my home network: pi-hole is working perfectly well on a raspberry pi on all the macs and iDevices, but after a recent software update (coincidence or correlation?), every ad is showing up on the one PC laptop using Chrome browser.

Am trying to make sense of the above discussion. Will need to have my personal IT manager (my stepson) help me out with this issue.)

Edit 1: Wait! It's a Chrome browser issue! I just tried using the new Microsoft EDGE browser, and pi-hole seems to be doing it's job. What's up with Chrome on a PC that is preventing pi-hole from working?

They likely have DNS over HTTPS enabled by default. This bypasses Pi-hole. Disable that "feature" and the DNS queries should go to Pi-hole.