Not seeing expected domains blocked

Expected Behaviour:

I should not be able to visit a website for a domain that is in an adlist.

I am new to Pihole. Just installed it on a RPi 3 last night. I'm using the admin web interface and on my Win10 PC I have set it to use the Pihole as primary DNS server with 8.8.8.8 as secondary. I have also ran ipconfig /flushdns.

It appears to be blocking standard Windows telemetry connections from what I can tell. But when I was visiting random websites I was still seeing ads. I found the following Blocklists:

As a test I added the tiktok.txt blocklist to Pihole. I am new to Pihole but from what I understand you add the list, then you goto Tools > Update Gravity and Update that. I guess this processes/compiles the adlists?. This process appeared to work fine without issue.

So now Pihole shows that there more domains in the adlist. When I look on the Tiktok adlist I can find for example tiktok.com. So since that has been added to Pihole doesn't that mean that I should not be able to access it? Should it resolve to 0.0.0.0 ? Because I can still visit tiktok.com in my web browser just fine. Although I cannot ping it on the command line. So that is odd...

What am I doing wrong here? I am new to Pihole so I feel like there is just some fundamental thing about it I am misunderstanding.

Actual Behaviour:

I can visit the websites fine and they don't appear to be blocked even though they are on my adlist.

Debug Token:

https://tricorder.pi-hole.net/3u6DSKr5/

Oh so you are suggesting that my secondary DNS (8.8.8.8) is actually resolving some of these domains? I guess I always assumed that the way DNS worked was that the secondary DNS would only be used if the primary DNS server was unreachable.

If you look at the output from /ipconfig you can see that there is no designation for primary or secondary DNS.

   DNS Servers . . . . . . . . . . . : 192.168.88.4
                                       192.168.88.5

The only way to have more than one DNS server with priority is to use a strict order option that does not exist for Windows.

Wow I never knew that. Removing the "secondary" DNS did the trick. Thank you,