Not blocking ads

Hi guys I'm new to Pi hole and Raspberry Pi as well. This is a great community and i will be contributing once my setup is up and running.

I installed the Pi Hole last night and it working fine but stopped working this morning. I have no clue what went wrong.

Here is my setup.

Raspberry Pi 3 B+ It was connected via Ethernet and Wifi. I'm using the WiFi IP for running WebCore on my Smartthings to broadcast on the Google home.

Installed Pi Hole with Static IP of my Raspberry Pi.
Router - Google WiFi and set the primary DNS as my Raspberry pi IP and secondary as

I have reserved the IP for the raspberry pi as well so the router will not assign this to any other devices.

It was working fine and i was so happy that I was able to block some site and worked awesome. I checked and no ads at all.

It is not working now and when i checked the DNS ip on my laptop it shows but this is not my Raspberry pi IP.

How do I fix this issue? Am I missing anything?

Thanks guys.

The Pi-Hole should be the only DNS listed. Having a secondary here allows some of your DNS traffic to bypass Pi-Hole.

Please send us the token generated by

pihole -d

or do it through the Web interface:

Thanks for the quick response. I have removed the secondary DNS from the router.

I will get back to you guys once i get home this evening with the token.

You should reboot the router and renew the DHCP lease on clients to ensure this change passes to all the clients.

It is still not working. I have removed the secondary DNS on the router.

I did reboot the router and release, renew and flushDNS on the client laptop.

Debug token is: vjlyokblf8

Your gravity list is empty. Run the following command to rebuild gravity. After rebuild you should have approximately 130K domains on blocklist.

pihole -g -f

1 Like

Yeah, It worked for blocking ads. Do I need to do this everytime? Yeah I remember seeing the gravity list last night but it was wiped out. What was the reason?

I have added the youtube to the blacklist but it is not blocking. Do I need to wait for sometime to work? I was trying to get the debug log but web interface is not loading now.

I had to reboot my Pi to get the log again. My blacklist is working now.

debug token is: ivjkj1b9yl

It's hard to say. During a gravity update, something must have not worked properly and the list became corrupt. If it happens again, update gravity again.

A post was split to a new topic: Pihole not blocking ads