Not blocking ads on android phone

Expected Behaviour:

Block ads on my phone in most apps

Actual Behaviour:

Doesn't block anything unless I use this app to change the DNS
It's also at like the android settings don't actually do anything but that app forces the change. But I'm not entirely sure I want to use that app for sensitive data, I have no idea what it's actually doing.

My router is a sky hub so it won't let me change dns settings AFAIK so I have to do it on all devices. I can get it to work fine on Windows devices but not android.

You can use Pi-Hole as your DHCP server. This will automatically assign all network devices to use Pi-Hole as DNS.

Ok I tried this and my pi isn't receiving an ip when I turn off dhcp. It's manually assigned in the router but I can't see how to assign it to the pi.

What should the dns address of the pi be?

You assign an IP to the Pi, and this is the address on which Pi-Hole is configured to listen.

What is the IP of the Pi currently?

ip a

Ok iv sorted that. And it blocked ads at first but after an hour they are back again... Any ideas?

Is this on all connected devices, or just for the Android phone?

Generate a debug log from Pi-Hole, upload it and post the token. We can take a look to see if Pi-Hole is working properly.

It just seems to be the Android phones. Iv tried a windows desktop and laptop and they both work fine as of yet.


Your Pi-Hole is working properly. The problem is likely that the Android phone has a separate DNS that it is using, allowing some or all of its traffic to bypass Pi-Hole. I would check some of the online forums for setting DNS on an Android phone.

I just changed both DNS 1 and DNS 2 to the pi hole address and it seems to be working for now, but I'll see how it goes. Previously I had pi hole as DNS 1 and DNS 2 was blank

Ok nevermind. They are back this morning... I give up.

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.