No internet on some devices after setting router to use Pi Hole as DNS server


#1

So i’ve successfully installed pihole and have been using it on my devices (mac, iDevices and mom’s Droid) by manually setting my DNS address to the pi hole’s static address. When I set my router DNS address to the pi’s and now the wii and bluray player couldn’t connect but my devices were working successfully. Where am I am screwing up?


#2

You shouldnt set your router’s (client) DNS IP to that of Pi-Hole.
You only need to set one IP address, that of Pi-Hole, in the DHCP server section of your router.


#3

I’m looking at my LAN settings as pointed in the first linked guide and that’s where I’m changing the DNS address to the pihole’s (just clarifying). I’m not seeing a DHCP server section, just an option to enable/disable DHCP. Honestly dunno why I’m not getting “it”.


#4

Never mInd I figured it out, I just disabled it on the router and enabled it on the pihole… disregard my stupidity.


#5

Some routers don’t support certain settings, such as changing the DHCP DNS address. Usually switching to Pi-hole for DHCP is the easiest option.


#6

Right, options for my netgear router are very… limited even in the advanced settings tab.