No filtering with Docker + Synology + Livebox

#1

Hello. I installed Pi-hole on a Synology with Docker, but I have no filtering. I manually entered DNS on the network card of my computer, the IP of the PI-hole, but nothing works. Does somebody have an idea ? Thanks for your help.

2019-02-16_11h16_37 2019-02-16_11h16_57 2019-02-16_11h17_53 2019-02-16_11h18_17 2019-02-16_11h19_26

0 Likes

assigned diginc #2
0 Likes

#3

Try using the image:tag pihole/pihole:dev, it resolves the issue 419, which is what you’re dealing with I think.

An official release (non dev) should be out with this fix within a day or two.

0 Likes

#4

Thank you. Yes it’s done, but I have the same problem.

0 Likes

#5

@Scolette you may need to delete your volume data

0 Likes

#6

I don’t understand your answer :open_mouth:

0 Likes

#7

pihole/pihole image has been updated to be 4.2.2, it should have the fix. Follow docker update instructions to pull and replace your old container with the new version.

If you’re still having problems make sure you delete your docker volume adlists.list file to re-populate.

0 Likes

#8

Ca semble logique, sur la configuration de ta Livebox, tu as laissé les adresses IP DNS de ta livebox alors que tu es supposé mettre l’IP de ton synology… Je pense que ton ordi se connecte directement à la passerelle 192.168.1.1 et celle-ci lui dis que le dns est celui d’orange et non ceux de pi-hole…
Sauvegarde les DNS d’orange, met qu’un seul DNS (adresse synology) et refait un test complet…

English:
It seems logical, on the configuration of your Livebox, you left the DNS IP addresses of your internet supplier while you are supposed to put the IP of your synology … I think your computer connects directly to the gateway 192.168.1.1 and this one tells him that the dns is not the one of pi-hole …
Save the DNS of your internet supplier, put only one DNS (address synology) and make a complete test …

0 Likes

#9

Hello smoutch. Thank you for helping me.
It is not possible to change the DNS on the livebox, the Orange operator does not allow it. I tested on my computer with a fixed ip, in gateway the IP address of the livebox and in DNS, that of the NAS Synology, but there is no filtering

0 Likes

#10

Next solution could be to desactivate the DHCP on the livebox and set up the DHCP server on your synology and therefore you will be able to bypass the livebox issue…

0 Likes

#11

Hello,
This is not possible because the livebox delivers DHCP via a vlan to the TV decoder for ADSL television.

0 Likes

#12

I temporarily turned off the livebox’s DHCP and turned on the PI-Hole’s DHCP but my client is unable to recover the DHCP from the Pi-Hole.

0 Likes