No DNS activity

This will bypass Pi-hole.

Looking at your debug log, I can see your router is advertising itself as DNS server:


This means every device inside your network will send queries to your router and your router will send the queries to one of the servers you set.

As there is no real concept of primary/secondary DNS, if both servers are working, both will be used by your router. Your router is choosing the "secondary" most of the times and sending most of the queries to

You set and on your router WAN settings (this is why Pi-hole is receiving queries only from your router).

You can try to change the DNS servers in your LAN settings. Notes:

  • the name of these options vary from router to router. Sometimes it is called DHCP settings, sometimes Local network. Sometimes this is hidden in a "Advanced" tab or page).
  • Not every router has these options.

If you change the DNS settings in LAN side, you can change the WAN DNS back to public server, like and