No device IPs in Client logs

Please follow the below template, it will help us to help you!

Expected Behavior: Client list should show devices IPs

Actual Behaviour: Only see Router ( and cpe (IPV6 address),localhost, raspberry pi, ::1

Debug Token:g2ypgot6ga!

First post anywhere as a pihole user. I have limited understanding of what I have managed to get working. As my setup is now the ad blocking works on all 11 of our devices on our home network. Woo hoo!! Love that.

I could have posted many times before but really did not know what to ask and feared I wouldn't be able to follow what I was told anyway.
Through extensive reading I have learned how to ssh into the raspberrypi3B+ with Putty from my laptop and use the command box. (I used a mouse, keyboard and monitor to set it up). I have managed to put the pihole interface on my android phone.
I believe that I have set my router up properly to use the pihole DNS. (It is a Netgear Nighthawk AC2400) It is not capable of being updated with advanced firmware and it also does not have DNSmasq settings.
I have read in one of the FAQ's that even if the router is setup correctly (to use pihole's DNS)that it may still not work properly AND that I may not be able to change that behavior.
I have looked at using conditional forwarding, but there is no domain name (ie blank) in the Netgear so pihole won't proceed with that setup.
I was going to use the pihole's DHCP server but when I tried that everything went haywire. Yes I disabled DHCP in the router, but my netgear has DHCP settings in 3 different places (2 in IPV6 setup) and I don't believe there would be anyone able to tell me exactly what the settings in my router would have to be for that to work.
I should also mention that I have reserved IP's for all devices in my router in lan setup. They are all holding up with no issues at all.
So I guess my question is why are the individual IPs not showing up?
Another thing I learned was how to add host names in /etc/hosts but that didn't work but I guess because the pihole is not even seeing the individual IPs anyway!
I hope I have laid out what my situation coherently enough for one of your whizzes to point me in the right direction or at least tell me I can't because of my router.
Thanks, Ron

This guide has all of the advice we can give. Usually the only way to workaround a router which hides client DNS queries is to use Pi-hole for DHCP:

Your debug log shows that the Pi has processed DNS queries from 6 clients in the 24 hours prior to your local time shown below:

   [2019-03-10 10:38:37.286 3672]  -> Total DNS queries: 43082
   [2019-03-10 10:38:37.287 3672]  -> Cached DNS queries: 6983
   [2019-03-10 10:38:37.287 3672]  -> Forwarded DNS queries: 13906
   [2019-03-10 10:38:37.287 3672]  -> Exactly blocked DNS queries: 22193
   [2019-03-10 10:38:37.287 3672]  -> Unknown DNS queries: 0
   [2019-03-10 10:38:37.287 3672]  -> Unique domains: 1385
   [2019-03-10 10:38:37.287 3672]  -> Unique clients: 6
   [2019-03-10 10:38:37.287 3672]  -> Known forward destinations: 4

To see which clients have been connected, run this command from the Pi terminal - this will show you all the clients that have connected, along with the number of queries from each:

echo ">top-clients withzero (15)" | nc 4711

I have tried setting up and using the pihole dhcp server again. I have been knocking it around and it appears to be working and my internet connection seems to be holding up. And the adblocking is still working as before. I am seeing device names as well as ip of devices on our network. I have a whole lot to look at. It is a little out of kilter but seems to be ironing out the kinks as it goes. JFB,I had flushed all the logs to start anew but I was able to run that command. I have restarted and rebooted all of our devices. I have not changed anything on my IPV6 router settings yet, but it appears that IPV6 stuff is still being blocked. I am in over my head with this whole deal, but I really do like what the pihole does. It has most certainly helped our home network.
Thanks, Ron

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.