No Access to Admin SSH works fine


#1

Expected Behaviour:

Trying to access admin interface 192.168.xxx.xxx/admin
SSH fine to 192.168.xxx.xxx
work again after reboot

Actual Behaviour:

Firefox can’t establish a connection to the server at 192.168.xxx.xxx
pihole updatePihole
[i] Checking for updates…
[i] Pi-hole Core: up to date
[i] Web Interface: up to date
[i] FTL: up to date

[✓] Everything is up to date!

As mentioned SSH work fine at ip address, address set statically. Using Dietpi 6.21.1 but installed from command line if memory serves.
Network is functioning, ad blocking seems to be working, pretty confident the problem is the webserver but not sure how to check. Have rebooted twice. Hasn’t been up long.

Debug Token: xxas4205a0!


#2

root@PiHole:~# curl -I 192.168.xxx.xxx
curl: (7) Failed to connect to 192.168.xxx.xxx port 80: Connection refused

Pinging 192.168.7.6 with 32 bytes of data:
Reply from 192.168.7.6: bytes=32 time<1ms TTL=64
Reply from 192.168.7.6: bytes=32 time<1ms TTL=64
Reply from 192.168.7.6: bytes=32 time<1ms TTL=64
Reply from 192.168.7.6: bytes=32 time<1ms TTL=64

Have also tried from my phone with safari and Firefox.

Guessing the output of curl command run from ssh points to actual problem.


#3

You don’t need to hide the IP ranges on your LAN - everybody else uses the same ones and hiding them makes it difficult for others to help resolve your problem.

The problem is that the webserver used by Pi-Hole (lighttpd) is not running:

*** [ DIAGNOSING ]: Pi-hole processes
[✗] lighttpd daemon is inactive

Your setup variables show the following options chosen:

*** [ DIAGNOSING ]: Setup variables
    ...
    INSTALL_WEB_SERVER=false
    INSTALL_WEB_INTERFACE=true
    LIGHTTPD_ENABLED=false

#4

Was working fine last night I didn’t reboot device.

Pi-Hole 3b+ with poe hat fed from a 150w poe switch. All my network gear is plugged into 1500 smart ups.

Have changed default password. Is the fastest way just to run setup again?

Understand permanent logging is still in development stage?

Don’t use the same ranges as anyone else. Old habit I guess.

Bokko


#5

There is a log at /var/log/pihole.log retained for 5 days, and a long term database at /etc/pihole/pihole-FTL.db that contains up to 365 days data. Is this the logging you are referring to?

Edit - /var/log/pihole-FTL.log is also retained for 5 days


#6

The fix to enable the web interface is to run pihole -r and select the “reconfigure” option.


#7

as root pasted below into ssh

curl -sSL https://install.pi-hole.net | bash

chose option to keep my settings
Watched consol did notice a mention of missing lighttpd index something in red

My only question is how did it stop and go missing.

Is it recommend to install this on dietpi or should I use raspian instead?

I have the admin interface back

Thanks


#8

We may never know.

Users run this on DietPi with no problems. I use Raspbian Stretch with no problems.

The file does not always exist, and lack of file does not indicate a problem.


#9

If I remember dietpi updates itself automatically…might explain that.

Raspian does not update unless told to I believe I read?

Many thanks for your time.

On logging I love the gui I just noticed my Mac isn’t going to sleep all day.
My HTR receiver is making the 2nd highest DNS requests in the house (it was powered down most days need to investigate that).

Cheers


#10

This is correct.


#11

Most servers are not configured to auto update/upgrade as things might break without the sysadmin knowing about it.
With servers, you always want to test major updates first in like a sandbox environment or a phased update with one server, out of several redundant servers, at a time.
Auto update/upgrade might be a nice feature for client devices but not for servers.
Plus you can configure Rasbian to perform auto update/upgrade if want it to.