Newbie braucht hilfe bei DNS Einrichtung


#1

Hallo zusammen,
per Zufall bin ich auf den Pi-Hole gestoßen und muss sagen, dass das eine super Sache ist.
Ich habe mit dem Raspberry nicht allzuviel Erfahrungen und brauche an manchen Stellen evtl. eine Step by Step Anleitung. Ich habe natürlich ein wenig recherchiert und je mehr ich gelesen habe, desto unsichere wurde ich. Ich habe bezüglich DNS und IP Adressen v6 einige Unklarkeiten die im besten Falle beseitigt werden könnten :slightly_smiling_face:

  1. Der Pi-Hole auf dem Rasp hat eine eigene fest IP-Adresse im IPv4-Feld 192.168.1.34. Diese IP habe ich in der Fritzbox 7490 unter den:
    Einstellungen ->Internet->DNS IP 4 eingetragen.
    Diese IP wird auch auf dem Pi-Hole unter:
    Setting-> Network Information->Pi-Hole IPv4 address mit 192.168.1.34 angezeigt.
    In dem Feld:
    Setting->Network Information->Pi-Hole IPV6 address steht nichts, das Feld ist leer.
    a. Wie bekomme ich die IPv6 Adresse des Pi-Holes/Rasp heraus?
    b. Wie trage ich dann die IPv6 Adresse in das leere Feld des Pi-Hole Feld?

Ich würde dann diese IPv6 Addresse auch gerne in der FB unter:
Einstellungen ->Internet-> DNS hinterlegen

  1. Im Pi-Hole habe eine Custom IPv4 und eine Custom IPv6 des zweier DNS Anbieters eingetragen.
    Pi-Hole hat von sich aus schon DNS Server z.b. OpenDNS hinterlegt. Dort kann ich nur IPv4 Kästchen anhacken, die Kästchen unter IPv6 sind ausgegraut.
    a. Muss das so?
    b. Wenn nein, wie ändere ich das bzw. muss das geändert werden?

  2. Auf der FB habe gibt es unter:
    Heimnetz -> Netzwerkeinstellungen -> IPv6 Adressen ->
    eine Menge Einstellmöglichkeiten.
    Es wäre schön, wenn mir einer sagen könnte, was für Einstellungen ich dort vornehmen muss.

  3. Hier im Haushalt sind eine ca. 30 Clients unterwegs. Die meisten mit Android und andere Wlan Geräte. Welche DNS IP trage ich dort ein? Die IP der Fritzbox oder die IP des Pi-Holes. Das ergibt beides irgendwie Sinn, oder?

Hinweis: Alle Updates auf sämtlichen Geräten sind eingespielt. Provider ist die Telekom mit VDSL 100

Danke für eure Mühe.


#2

Zu Frage 1-3:
Scheint so als ob du bei der Installation IPv6 nicht aktiviert hast.
Was du aber eigentlich nicht brauchst. Ich habe in meiner Fritzbox IPv6 deaktiviert und arbeite auch nur mit IPv4.
IPv6 wurde eingeführt weil den Providern die IP Adressen aus gehen. Bei dir im LAN kannst du mit IPv4 und den Standart Einstellungen dazu 255 Clients “versorgen” das sollte im Privaten Bereich lange reichen.
IPv6 bringt dir sonst weiter nichts und macht dir vieles nur zusätzlich komplizierter.

Zu Frage 4:
Wenn du dein Pi-hole in die Fritzbox richtig eingetragen hast wird der DNS Server vom DHCP Server automatisch angegeben. Wenn du die IP Adressen Satisch von Hand vergibts musst du natürlich als DNS Server die IP von der Pi-hole angeben und den alternativen DNS Server läßt du leer bzw. 0.0.0.0 .
Für die Fritzbox gibt es hier schon x Beiträge…


#3

Hallo,
danke für die Antwort.
Wo deaktiviere ich IPv6?
FB->Internet->Zugangsdaten->IPv6->IPv6-Unterstützung? oder
FB->Heimnetz->Netzwerk->Netzwerkeinstellungen->IP-Adressen->IPv6-Adressen und dann deaktivieren DHCPv6 Server im Heimnetz oder DNSv6 Server im Heimnetz?


#4

hier den Hacken raus nehmen.

guten Rutsch :slight_smile:


#5

Danke für die Hilfe.
Ich habe den Hacken raus genommen, leider konnten alle Clients nicht mehr auf Netz zugreifen. Also IPv6 hacken wieder gesetzt.

Leider führt das auch zu meinen ursprünglichen Fragen, und bräuchte nochmal etwas Hilfe.

Vielleicht kann ich mich weiter durchwurschteln, wenn ich wüsste wie ich nachträglich IPv6 im Pi-Hole aktivieren kann, wobei ich mir sicher bin, das Sternchen bei der Erstinstalltion nicht herausgenommen zu haben.

Danke


#6

Am besten rufst du die Konsole auf, um pi-hole noch einmal neu zu konfigurieren.

Dazu einfach pihole -r eingeben!


#7

Hab ich gemacht. Bei der Rekonfiguration waren bei IPv4 und IPv6 jeweils ein Sternchen. Nach der Rekonfiguration wurde mir KEINE IPv6 Adresse angezeigt. Muss ich die Sternchen entfernen damit IPv6 mit installiert wird?

Es waren auch alle Filterlisten weg und wurden auch nicht nachgeladen, Jede Liste hatte eine Fehlermeldung.

Ich werde das System komplett löschen und nochmal aufsetzen. Habe mir das irgendwie einfacher vorgestellt…

Update:
Nach einer langen Nacht und ein Crash-Kurs mit “cat” und “nano” und Root-Rechten etc. läuft das System mit IPv6.
Das Problem war wohl, dass ich den RP am Switch hatte und nicht direkt an der FB.
Im Pi-Hole sollte man auch nicht “DNSSEC” aktivieren. Dadurch werden die Blocklisten nicht eingelesen.

Trotzdem noch eine Frage
Im Pi-Hole unter Setting->DNS->Interface listening behavior wo sollte hier der Hacken gesetzt werden?