New VM - fresh pihole install not working outside the VM


#1

Please follow the below template, it will help us to help you!

Expected Behaviour:

pihole is reachable from local network on HyperV - Mint linux VM (192.168.100.2 GW: 192.168.100.1)

Actual Behaviour:

pihole runs as expected on the VM, can reach GW, can ping external.
network clients cannot nslookup to the VM pihole machine. get timeout.

I can reach the pihole Admin site from external clients

nslookup www.yahoo.com 192.168.100.2
DNS request timed out.
timeout was 2 seconds.
Server: UnKnown
Address: 192.168.100.2

Port 53 is not reachable either outside the VM.
‘telnet 192.168.100.2 53’
Connecting To 192.168.100.2…Could not open connection to the host, on port 53: Connect failed

Firewalls are all disabled on the Hyper V - Mint VM.

Debug Token:

Your debug token is: vzf7ollo37


#2

Mint depending on what version you are on has its own network manager that includes dnsmasq and blocks the ability of pihole to function as intended. this post PiHole on Ubuntu 18 on Odroid Xu4 may help


#3

Change the final line
#DNSStubListener=Yes
to
DNSStubListener=No

Mine is already set to No.
Mint version 19.1 XFCE

That does not seem to be the issue. Though networking and pihole on Ubuntu 18.10 or Mint 19.1 has the same issue. External clients cannot query Pihole for DNS. Only localhost queries resolve for pihole.

What OS versions are supported for pihole currently?


#4

https://docs.pi-hole.net/main/prerequesites/#supported-operating-systems


#5

sudo netstat -lnp | grep “:53”

shows its
systemd-resolve that already has port 53 open before I install pihole.

is there a way to disable that and use 53 for pihole? This VM is just for pihole…


#6

#7

I tried this and then installed PiHole. The PiHole process owned the port 53 process after, but I could still not hit it from outside the box, and now testing internal to the box IP failed. I guess I’ll abandon trying on these new OS versions…


#8

Can you ssh to 192.168.100.2 ? It sounds like a firewall issue (you can do everything from inside to outside but nothing from outside to inside).


#9

The FW was disabled. I can hit the admin site on 80 from outside. No DNS queries, nslookups, or telnets to 53 work on the latest Ubuntu or Mint versions… Admin http worked fine…