New Install, Final Hurdles?


#8

Something went wrong there, i’ve lost internet access from the pihole, followed these instructions - https://askubuntu.com/questions/907246/how-to-disable-systemd-resolved-in-ubuntu

Solved that part - re-creating the network connection did the trick, though nothing looks any different to the previous one!

Annnd… Bingo! I’m now seeing the queries come through, only from localhost though


#9

Did you reinstall dnsmasq?


#10

Actually, i was seeing queries when i first repaired pihole but nothing has logged since

And my mobile (test device) is showing no internet on the wifi connection


#11

The repair was after removing systemd-resolve?


#12

Yep, last thing i did


#13

Try rebooting the device after making all the changes.


#14

It’s logging promptly for sites called from the pihole, but still showing no internet on my test device. Presumably this is now something related to the router configuration - do i need to set a port to the pihole IP in my DNS settings maybe?

Running on ASUS Merlin dd-wrt so rather than a network-wide configuration i’ve only assigned one device to use the pihole so far


#15

Devices should use port 53 by default, so you shouldn’t have to do anything. Send a screenshot of where you are setting Pi-hole as the DNS server. We also have an FAQ for different ways to set it up.


#16

Plan to go with the hosts file approach to this, but for the moment i’ve got opendns working on some devices that i will change over in due course.

This is under AI Protection in asus merlin

Edit: removed image containing MAC addresses


#17

It looks like you would want to use “Router” mode to force the DHCP clients to use Pi-hole for their DNS server. But you said you weren’t going for the network-wide method, so I’m confused.


#18

There are two places you can configure DNS on this firmware, at router level or at client level. If i were to select Router then the default config there is to go out to OpenDNS or quad8 as a failsafe, but i’m trying to separate it out. Separating might not be necessary if i get the hosts file set up properly but the limitations of OpenDNS are what led me to be device specific, the other advantage of setting it here is that i can quickly disable this remotely if the pihole were to go down


#19

That makes sense. In terms of verifying that Pi-hole is working, can you manually set a device to use Pi-hole? After that, you know things are working so it’s just a matter of configuring things in your router.


#20

I have and it isn’t, device shows as having no internet. I’ve tried setting the DNS server in the other configuration point too and switching to router but no change.

Is there configuration somewhere i’ve missed to only log/acknowledge from localhost?


#21

sorry see what you mean about manually setting a device, trying now


#22

Try sending another debug token and let’s see how things look.


#23

tried manually from a windows laptop and no dns

new debug log is amv5s5baiy thanks


#24

It looks mostly OK. Can you

dig doubleclick.com @192.168.1.214
curl -I 192.168.1.214

#25
dave@dnssink:~$ dig doubleclick.com @192.168.1.214
curl -I 
; <<>> DiG 9.11.3-1ubuntu1-Ubuntu <<>> doubleclick.com @192.168.1.214
;; global options: +cmd
;; connection timed out; no servers could be reached
dave@dnssink:~$ curl -I 192.168.1.214
HTTP/1.1 200 OK
Content-type: text/html; charset=UTF-8
Date: Sun, 27 May 2018 15:51:32 GMT
Server: lighttpd/1.4.45

#26

Figured it out and it’s my fault, i changed the Interface Listening behaviour setting to listen on all devices rather than on the specific interface. This caused me an issue because i’m using a powerline kit until i relocate the device, which means an extra hop.

Happy days, thanks so much for your help!


#27

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.