Network tab - unknown error occured

Hi, i have installed pi hole latest version 2 days ago in a docker in my synology DS918, all seem s to run fine except the tab network, every timne shows me this error and nothing appears on it
any help would be appreciated

Your database file is broken (or incomplete):

*** [ DIAGNOSING ]: Pi-hole FTL Query Database
-rw-rw-r-- 1 pihole pihole 24K Jan 20 16:12 /etc/pihole/pihole-FTL.db

This file is too small (only 24Kb). An empty database should be at least 80Kb.

Also, you have many "no such table" errors like these:

SQLite3 message: no such table: network in "SELECT interface FROM network JOIN network_addresses ON network_addresses.network_id = WHERE network_addresses.ip = ? AND interface != 'N/A' AND interface IS NOT NULL;" (1)
SQLite3 message: no such table: network_addresses in "DELETE FROM network_addresses WHERE lastSeen < 1674429240;" (1)

To fix the issue, run these commands to move the existing database to a new file name and create a fresh database.

sudo service pihole-FTL stop

sudo mv /etc/pihole/pihole-FTL.db /etc/pihole/pihole-FTL-old.db

sudo service pihole-FTL start


Thanks for the response

Where i can use these commands in my nas? i have tried enabling ssh and then from windows 10 cmd log in, but after typing the first command it says "sudo: service: command not found"

I found in the docker settings of pi hole a tab with terminal, is this place where may i have to run these comands?

Yes, with a dockered Pi-hole, you'd have to run them inside the container.

You could also stop your container, remove the db from the mounted directory of your host, and restart the container, but that would require that you had configured your container to expose /etc/pihole/ (which we don't know from what you've shared so far).

The commands i have writed it seems that the have nort worked but later terminal says that ftl was stopped, after that y shutdown and restart pi hole and now it works (this is something that i did few times after write in the forum)

I don't know why but it works now

thanks for your help!