Lost Connection to Router


#1

Hey Pi-Hole Team!

So I have run into an interesting issue that I didn’t understand fully until today. Long story short, the router I have (Verizon Fios G1100) has been set as follows:

  • DNS Set to 192.168.1.201 (Pi-Hole)
  • DHCP Server disabled
  • Static IP set to 192.168.1.201 (Pi-Hole)

My Pi-Hole is set as follows:

  • DHCP Server Enabled

The Issue…

Basically, what I have found out is that the only way to get my device to work as a DHCP server is to first enable the DHCP server on my router, then restart my Pi-Hole device, and then disable the router DHCP server.

The problem is that then after the assigned 1440 minutes (24 hours), or a restart, the device self-disconnects breaking everything else and the process has to be repeated.

What am I missing here? There’s got to be something that I am doing wrong here that would make it so it doesn’t stay connected correctly?

I did attempt to set it up as a static IP on the device not just on the router through the Ubuntu 16.04 settings. It hasn’t been 24 hours so I don’t know if that will fix it (Device is set to a static IP of 192.168.1.201 / Mask: 255.255.255.0 / Router: 192.168.1.1 via Ethernet) but otherwise? What am I doing?

Debug Token:

73ptmzuapo


#2

It sounds like the Pi-hole device does not have a static IP set, and is using the DHCP lease from the router until the lease runs out.