Logging issues when pihole is set as DNS server in router

I have pihole set up on my network with a static IP, and I changed the DNS server in my router to point to the pihole. This setup "works", in that DNS queries go through the pihole and are appropriately filtered. Unfortunately, the main reason I wanted to switch from OpenDNS to pihole is to improve the logging and track down who is making certain requests on the network. Unfortunately, the pihole logging is close to useless in this configuration.

Expected Behavior:

I want to see the IP address of the computer or phone making the DNS request.

Actual Behavior:

The IP address is always logged as the IP of the router, not the router's client.

Debug Token


How can I keep the settings automatic/router-centric without also making the logging useless for identifying clients? Changing the DNS manually on each device on the network is pretty much out of the question due to the size of the network and the devices constantly rotating in and out.

This is an issue with how your router handles DNS. If you can not change this behavior on the router, you need to switch to Pi-hole for DHCP:

1 Like

Any idea what setting I should look for on my router to try and change this?

There may be a setting called "Internal DNS", but it is best to look in the manual for any settings which may disable this internal forwarding.

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.