Localhost is the only topclient


#1

I installed Pi-hole two days ago, and I am still evaluating if it is functioning correctly, as the logs are not being generated in the way that I think they should based on tutorials. I am using a router w/ OpenWRT and edited the default DNS under interfaces ->

When I check this website it says adblocking enabled - https://blockads.fivefilters.org/?pihole

Expected Behaviour:

Router and localhost will be listed as Top Clients, more logs generated.

Queries will be visible, blacklisting specific sites will work.

Actual Behaviour:

only localhost is listed

No queries displayed -

Sites added to blacklist not blocked.

Debug Token:

tt57hca5er


#3

There are several errors shown in your debug log that indicate the Pi-Hole is not connected to your network properly:

There is no IP address assigned to the Pi-Hole on the ethernet gateway where Pi-Hole is listening:

*** [ DIAGNOSING ]: Networking
[✗] No IPv4 address(es) found on the eth0 interface.
[✗] No IPv6 address(es) found on the eth0 interface.

[i] Default IPv4 gateway: 192.168.1.1
   * Pinging 192.168.1.1...
[✗] Gateway did not respond. (https://discourse.pi-hole.net/t/why-is-a-default-gateway-important-for-pi-hole/3546)

Pi-Hole is not resolving queries using the IP address it is configured for (192.168.1.128). Note that it can resolve using itself, so it’s set up properly on the Pi. The problem is the Pi connecting to your network.

*** [ DIAGNOSING ]: Name resolution (IPv4) using a random blocked domain and a known ad-serving domain
[✓] pisosribarroja.es is 0.0.0.0 via localhost (127.0.0.1)
[✗] Failed to resolve pisosribarroja.es via Pi-hole (192.168.1.128)

*** [ DIAGNOSING ]: Setup variables
    PIHOLE_INTERFACE=eth0
    IPV4_ADDRESS=192.168.1.128/24

#4

ok I now checked “DHCP server enabled” w/ my range in settings on the admin panel but still no go .

Should I change interface from eth0 to wlan?

And how would I alter the ethernet gateway? The pihole pi is on shown on the router’s arp tables and I can ping the router from the pi

[✓] Your debug token is: 1clvj8topy


#5

If you have DHCP enabled on your router (and from your first debug log it appears you do), you don’t need to enable this on the Pi-Hole. This gets two DHCP servers running which typically causes problems on a network. Turn off DHCP on your Pi-Hole.

You set up the interface for whichever way you are connecting the Pi to your internet (ethernet or wireless). Is your Pi connected via ethernet or via wireless to your network?

Your new debug token shows the same problem - no IPv4 address on eth0, the interface on which Pi-Hole is listening.


#6

fixed, wlan0 is now set. Looks like the one issue is ipv6 not resolving for a DNS request and dnsmasq not active - should I activate dnsmasq as well? If so what would be the best way for this?

[✓] Your debug token is: ldzxzss68y

Thank you very much for help thus far!


#7

With Pi-Hole V4, dnsmasq is embedded in pihole-FTL and pihole-FTL runs in place of dnsmasq. The debug log will typically show dnsmasq as “failed” or “inactive.” You should not activate dnsmasq as a separate process.

Your debug log is normal for this:

*** [ DIAGNOSING ]: Ports in use
*:22 sshd (IPv4)
*:22 sshd (IPv6)
*:80 lighttpd (IPv4)
*:80 lighttpd (IPv6)
*:53 pihole-FTL (IPv4)
*:53 pihole-FTL (IPv6)
127.0.0.1:4711 pihole-FTL (IPv4)
[::1]:4711 pihole-FTL (IPv6)

*** [ DIAGNOSING ]: Pi-hole processes
[✗] dnsmasq daemon is inactive

You don’t have an upstream IPv6 DNS server specified, just the two Google IPv4 servers.

PIHOLE_DNS_1=8.8.8.8
PIHOLE_DNS_2=8.8.4.4

#8

ok thanks, I’m testing it by going on adladen websites that are recommended for testing pihole. After going on this site for example there are no new hits in the admin panel https://www.scarymommy.com/i-dont-like-being-a-mother/ and the page still displays ads interspersed in the text. I also am able to still go on a domain that I added into the blacklist w/ the REGEX * (^|.)domain.com$


#9

That could be a case of your router or client providing an alternate DNS (i.e. not Pi-Hole) that the client is using to get those domains. If you recently set this up, you may have to renew your client DHCP leases to pick up the new DNS information.

Some routers have DNS settings buried in various menus and it sometimes takes a bit of digging to find them all.


#10

restart and or reset the router?


#11

Restart the router almost never hurts. Resets are not usually desired; you lose your settings.


#12

thanks - restarted router, I am seeing the other devices in Top Clients and the data on the admin panel is updating, but ads are still visible on pages like this https://pythontips.com/tag/python-patreon/


#13

everything appears to be working thank you