Local Domains not reachable from other Devices

I am having an issue with my local domains, that are configured in Pi-hole on my Raspberry Pi with the latest Raspberry Pi OS Lite (64 Bit).
Every single service is working as it should and the normal functionality of Pi-hole also works perfectly, except the local domains.
The pis address is used in my router settings as DNS and Local-DNS Server. I used the same setup like two days ago, but I installed Pi-hole directly on the pi instead of using docker and the local domains worked back then. It is probably an issue with the docker setup and maybe something that i configured wrong since I am pretty new to raspberry pis, docker etc.

Pings from the pi itself work fine but pings from my personal (windows) pc don't work.

My docker container setup is shown below.

The Pi-hole bebug log can be seen here.

I've read that this error is common with raspberry pis and schould not be a problem.

I haven't read anything useful about this error though, but it could possibly be connected to the above.

My router acts as DHCP server, and these are my Pi-hole DNS settings:


  • never forward non-FQDN A and AAAA queries
  • never forward reverse lookups for private IP ranges
  • use DNSSEC


  • conditional forwarding
  • permit all origins

Could it be a problem that all my local domains are pointing at my pi?
raspberry.local / raspberry → (the pis hostname)
vaultwarden.home →
nextcloud.home →

Using nslookup with a specified DNS server works.

I don't get why it doesn't work without specifying a DNS server since ipconfig returns that the correct DNS server is being used. I also tried to set the DNS server manually which again didn't work.

Your Pi-hole is hosted on
Your nslookup via that IP shows that Pi-hole provides the expected replies - if it is queried, that is.

Your client is using your router's IPv6 address instead, i.e. your router is advertising its own IPv6 as DNS server, allowing clients to by-pass Pi-hole.

As your router is of a Fritzbox variety, you can configure it to stop doing so, e.g. Unresolved ipv6 adress in my top list - #4 by Bucking_Horn.

1 Like

This solved it, thank you very much.

For people looking into this in the future: close all cmd-windows before trying to check the connection again.

Glad it's working. :slight_smile:

From your debug log, I've noticed that your Pi-hole container isn't aware of its host's IP address yet.

You should consider feeding your into that container's FTLCONF_LOCAL_IPV4 recommended environment variable.

1 Like