Little Snitch (& Pi-hole) - LS resolving address to Pi-hole - Solved


#1

I’m looking for Little Snitch users here, not really a Pi-hole problem. :wink:

I use LS in parallel to Pi-hole to restrict traffic whenever I’m on the road (or at a client) where there’s no Pi-hole.
In the Pi-hole log and Dashboard I get lots of inspiration of what to add to LS.

And there is my problem:
In the Pi-hole log I see: ads.spam.it
Pi-hole blocks it by returning its own IP, say: 192.168.1.1
Now I want to add a rule in LS to block ads.spam.it.
But as soon as I enter “ads.spam.it” to LS, it is resolved to the local IP of the Pi-hole server, thus
a) effectively blocking my access to the Pi-hole dashboard (since LS then block access to 192.168.1.1) and
b) not working when I am in a different environment (since 192.168.1.1 is not the real address of ads.spam.it).

I’ve tried to deactivate Pi-hole for the time while I create the rule in LS. Did not work.
I’ve tried the above and in addition cleared my arp cache (sudo arp -d -a). Did not work.
I am able to add the rule to LS properly when outside my own network, but thats not the solution.

How do you guys/gals add new rules to LS while Pi-hole is working its magic? Any solution?


#2

if you can have little snitch trigger on 0.0.0.0 perhaps checkout the dev branch and enable null as your blocking mode in the FTL conf


#3

Hej technicalpyro,
thanks, but that is more technical than I understand.

I need to enter “ads.spam.it” into LS, as this is the domain name that should be blocked. LS then resolves the address and (because pi-hole is blocking it) returns 192.168.1.1. I can not change the IP, thus not to 0.0.0.0 or localhost or some 127/8 address.

I’ll read a little more about blocking mode, but as setting the IP ist the prerequisite in your solution, it probably won’t work. Are you using LS as well?


#4

not personally no. i am a mac user and more of a networking guy i could fire it up on my MBP to try and reproduce


#5

based on your above description nullrouting method of blocking would prevent your issues as when you add the website instead of it resolving the piholes address it will resolve to 0.0.0.0 and not prevent access to the website
OR
temporarily whitelist the website in pihole then add the rules in LS then re block the website in pihole


#6

temporarily whitelist the wqebsite in pihole then add the rules in LS then re block the website in pihole

omg. facepalm
i’m so dim…
yes, sure, that will most likely work. thanks technicalpyro … and … sorry… blush


#7

No worries only stupid question is the one you don’t ask


closed #8

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.