Laie braucht Hilfe bei der Einrichtung von Router und pi-hole

Hallo.
Habe eben pi-hole installiert, Blocklisten geladen und so weiter.
Im Webinterface sehe ich aber, daß lediglich der Router (D-LINK DIR-635) pi-hole nutzt.
Ich habe jetzt irgendwo im Router im Bereich “SETUP - MANUELLES EINRICHTEN DER INTERNETVERBINDUNGSOPTIONEN - DYNAMISCHE IP (DHCP) INTERNET-VERBINDUNGSTYP” die IP des pi-hole als primären und die 8.8.8.8 als sekundären DNS-Server eingetragen.
Ich komme mit den momentan angeschlossen Geräten (PC per LAN und Handy per WLAN) ins Netz. Aber weder Handy noch PC werden im pi-hole-Interface grün unterlegt. Sie nutzen also das pi-hole gar nicht. So macht das Ganze natürlich wenig Sinn.
Kann mir vielleicht weiterhelfen?
Danke

Hallo,

greifen wir den Hinweis von jfb auf und beginnen damit, dass du nur die statische IP des Raspi als primären DNS-Server einträgst. Ein sekundärer Server wird nicht eingetragen, das Feld für einen sekundären Server bleibt somit leer.

Ich habe gerade eben den Sekundären DNS gelöscht. Danach komme ich mit keinem der angeschlossenen Geräte mehr ins Netz. Okay. Jetzt habe ich tatsächlich weder Werbung noch Tracking auf allen Geräten. Aber sicher keine befriedigende Lösung.

Einerseits was @jfb und @mibere schon meinten: Es gibt keinen “primären” und “sekundären” DNS Server. Das ist missverständlich, denn man denkt zunächst naiv, dass der “primäre” der bevorzugte ist. Tatsächlich stehen die aber gleichrangig nebeneinander, d.h. es werden bei Deiner Konfiguration immer wieder Anfragen ungefiltert am Pi-hole vorbei an Google DNS weitergeleitet.

Das ist vermutlich bei dem Router dann so. Es gibt einige Modelle, die sich selbst weiterhin als DNS Server im Netzwerk anpreisen und die Anfragen dann gesammelt an das Pi-hole schicken. Letzteres kann dann leider nicht mehr auseinanderhalten woher die Anfragen kamen, denn für es kommt zunächst erst einmal alles vom Router selbst.

Vorsicht, das kann ein Trugschluss sein. Sie können das Pi-hole durchaus (über den Umweg ROuter nutzen). Diese Anzeige belegt lediglich was wir schon wissen: Keines dieser Geräte stellt Anfragen direkt an das Pi-hole.


Bearbeitung durch @mibere: @DL6ER, ich war so frei und habe “primitive” durch “primäre” ersetzt.

War’s das jetzt?
Dann bin ich - bis auf 3 neue Bekanntschaften - nicht wirklich weiter. :slight_smile:
Muß ich vielleicht im pi-hole irgendwo die IP des Routers eingeben oder so? Ich las irgendwo etwas in der Art.

Nein.

Doch.

Schlussfolgerung: Der Router scheint nicht sonderlich kooperativ:

  • Gibt man dort nur das Pi-hole ein, so gibt es kein Internet.
  • Gibt man außerdem Google ein, dann scheint er alles dahin zu schicken.

Lösung: DHCP Server im Router deaktivieren. DHCP Server im Pi-hole aktivieren. Dieser konfiguriert sich passend fürs Netzwerk. Alle Geräte bekommen dann automatisch Adressen mit den richtigen DNS Informationen zugewiesen.

Noch ein Hinweis: Die meisten Geräte müssen einmal kurz vom Netzwerk getrennt werden um eine neue Konfiguration anzufordern.

Habe jetzt DHCP im Router aus- und im pi-hole eingeschaltet, dann Router und raspberry neu gestartet. Zumindest komme ich noch mit allen Geräten ins Netz. Im Webinterface vom pi-hole ist nach wie vor nur der Router als pi-hole nutzend grün hinterlegt. Handy und PC nach wie vor rot.

Funktioniert auf Handy und PC der Aufruf der Adresse http://pi.hole/admin ?

Wenn ja, dann funktioniert die Anzeige in der Tabelle irgendwie nicht. Wenn nein, kannst Du mal einen Screenshot der Netzwerkdetails auf dem Rechner zeigen?

Mit dem Handy komme ich über http://192.168.0.197/admin auf das Webinterface des pi-hole. Über die von Dir genannte Adresse geht’s nicht. Weder mit Handy… noch mit dem PC.
Netzwerkdetails auf dem Rechner? Die finde ich WO? Ich habe an den Clients nach der pi-hole-Anleitung nichts geändert, stattdessen alles über Router und pi-hole geregelt.

Dann hat die Tabelle recht und es geht noch nicht.

Das kommt auf das Betriebssystem und dessen Version an.

Das ist okay wenn die auf dynamischer Konfiguration stehen. Nach dem Umschalten des DHCP Servers und dem Neustarten/Neuverbinden der Geräte hätten diese die neue Konfiguration direkt vom Pi-hole beziehen sollen.

Ich habe hier Windows 7 Ultimate laufen. pi-hole scheint zumindest etwas zu blocken. Wenn ich mit dem Handy auf www.rtl.de gehe oder für Werbung bekannte Apps öffne, dann sehe ich ein plötzliches Ansteigen der geblockten Anfragen. Ich kann also nicht sagen, es würde NICHTS passieren. Gibt es denn nicht eine Seite, ein Online-Tool, wo ich die Wirksamkeit von pi-hole testen kann? Momentan habe ich eine Quote von 1,9% geblockte Anfragen. Dafür die ganze Mühe?

Mit Windows kenne ich mich nicht aus, aber https://www.elektronik-kompendium.de/sites/raspberry-pi/1910011.htm schlägt vor, dass

ipconfig /all

die aktuelle Konfiguration anzeigt. Hier sollte nur ein DNS Server auftauchen und das muss die IP Adresse des Pi-hole sein.

Ein prominentes Beispiel ist https://www.linguee.de/

Hier gibt es mit Pi-hole keine Werbung, ohne ist alles ziemlich zugepflastert.

Die Prozentzahl ist ziemlich nichtssagend. Webseiten haben eine Menge Content und werden immer komplexer. Wenn nur wenig blockiert wird und die Werbung trotzdem eingedämmt/weg ist, dann trifft es nur das richtige.

ipcfg
Da steht überall die IP des Routers drin. Die des pi-hole ist nirgends hinterlegt.

Update:
Alles nochmal neu gestartet. Zumindest erscheinen Handy und PC jetzt in der Tabelle im Dashboard grün! Auch die Netzwerkdetails vom PC zeigen jetzt die IP des pi-hole an. Ich muß jetzt davon ausgehen, daß alles jetzt irgendwie funktioniert. Wie teste ich das jetzt am besten?

Update 2:
Habe den Router 1 Stunde nach dem vermeintlichen Erfolg vom Update 1 über eine vorher gesicherte config-Datei wieder in seinen Zustand vor den pi-hole-Experimenten zurückgesetzt, nachdem ich am Handy alle paar Minuten Verbindungsabbrüche und eine trödellahme Performance beim Laden von Webseiten hatte. Der Google Play Store kriegte keine Verbindung und, und, und. Also alles wieder auf Start. Seltsamerweise läuft das Handy dennoch über pi-hole und entsprechende Anfragen werden geblockt. Habe jetzt in den Netzwerkeinstellungen des PC auch noch die pi-hole-IP als DNS eingetragen und jetzt werden auch alle diesbezüglichen Anfragen gefiltert. Wollte eigentlich solche Änderungen an den Clients vermeiden, weil ich diese dann ja wieder rausnehmen muß, wenn ich mit denen mal nicht hier im Geschäft ins Internet will. Aber vielleicht findet sich ja auch da eine Lösung. Müßte erstmal sehen, welche sichtbaren Vorteile mir pi-hole bei den daheim angeschlossenen Geräten wie fire-tv und Switch bringt.

Hallo Webber,

ich glaube dass das eigentliche Probleme die fehlenden Grundkenntnisse im Netzwerkbereich sind. Und du deswegen an einigen stellen Schwierigkeiten hast
die Fehler genauer zu finden/erkennen.

Wenn wir jetzt einmal davon Ausgehen das Pi-Hole läuft und deine Geräte ihre DNS Anfragen über Pi-Hole schicken solltest du in so einem Fall wie dem Google Play Store als erstes mal in der Admin Oberfläche im linken Menü unter Query Log nach schauen ob der Google Store dort du die Blacklisten vom Pi-Hole geblockt wurde.

Wenn dem so ist und dies eigentlich nicht möchtest kannst du dort nämlich auch direkt die Freigabe aktivieren.
Denn das ist ja unter anderem Sinn und Zweck von Pi-Hole :wink:
Es werden die Einträge unter den jeweiligen Blacklisten geblockt.

Hier stellt sich z.B.: als erstes die Frage wie sich das Handy genau bei dir Zuhause mit dem Internetverbindet bzw. mit welchen Einstellungen.

Wenn das Handy keine statischen Einträge (IP Adresse, DNS Server, Gateway usw.) besitzt und rein weg alle Daten vom DHCP Server bekommt, liegt der Fehler nicht beim Handy sondern bei deinen Einstellungen vom DHCP Server. Ebenso die Lease Zeiten vom DHCP.

Welcher eben von Pi-Hole oder vom deinem Router sein kann.
Und dann müsste man dort den Fehler suchen und beseitigen.

Switch? was für Switch?

Hier kommen wir dann auch wieder zu den fehlenden Grundlagen im Netzwerkbereich…

Nutzt du etwas hinter deinem D-Link Router noch einen Netzwerk Switch?
Wenn ja, welcher Switch? wie ist dieser Konfiguriert? Ist auf diesem vielleicht auch noch ein DHCP Server aktiv?

Vielleicht solltest du erst einmal ein paar Screenshots von den Einstellungen in deinem D-Link Router erstellen und hier posten.

Also Einstellungen davon wie sich der Router mit deinem Internetanbieter “verbindet”
Sowie die Einstellungsmöglichkeiten vom DNS Server zum Internet/Internetanbieter…

Dann die Einstellungen vom Heimischen Netzwerk (LAN/WLAN)
Die Einstellungen vom DHCP Server im Heimischen Netzwerk usw.

Denn solange man deine eigentlichen Grundeinstellungen vom Router und deinem Heimischen Netzwerk nicht kennt wird es schwierig hier eine genaue Fehlersuche zu Betreiben. Danach kommen dann die Einstellungen von Pi-Hole sowie die Einstellungen der einzelnen Geräte Zuhause (Statisch oder DHCP usw.)

Grüße
MadM4x