Keine DNS-Auflösung nach Rechnerneustart

Ich hatte Pihole auf Debian 9, bin aber nun auf Ubuntu 18.04.x gewechselt, weil unter Debian die DNS-Auflösung nach einem Neustart nicht mehr funktionierte. Ich musste nach dem Restart immer ein Reconfigure ausführen, damit Pihole wieder ordnungsgemäß arbeitet.
Leider bin ich nun vom Regen in die Traufe gekommen, unter Ubuntu erhalte ich exakt das gleiche Verhalten. Wenn ich die Kiste neu starte, braucht es erst ein Reconfigure bis Pihole wieder DNS auflöst. Das nervt. Ich habe allerdings keine Idee, an welcher Stelle ich mit der Fehlersuche ansetzen soll. Bisherige Web-Recherche brachte nichts genaues…
Zur Hardware: Pihole läuft auf einem Fujitsu Futro S720:
OS: Ubuntu 18.04 bionic
Kernel: x86_64 Linux 4.15.0-47-generic
Shell: bash 4.4.19
CPU: AMD GX-217GA SOC with Radeon HD Graphics @ 2x 1.65GHz
GPU: AMD/ATI Kabini [Radeon HD 8280E]
RAM: 327MiB / 3619MiB
Software ist up to date, da jeden Sonntag Update-Tag ist.
Ich würde mich freuen, wenn jemand eine zündende Idee hat. Herzlichen Dank im Voraus!

Ist dem Interface, auf dem Pi-hole läuft - z.B. eth0, eine feste IP zugewiesen?

Danke für die Rückmeldung. Also nach meinem Verständnis ist dem Rechner eine feste IP-Adresse zugeordnet. Allerdings bezieht der Rechner die Adresse über DHCP, die feste Zuordnung erfolgt in der Fritzbox, wo eingestellt ist, dass immer die selbe IP-Adresse vergeben werden soll. Oder hätte ich die IP-Adresse im Rechner selbst fest verdrahten sollen?

Ja, gib dem Rechner auf dem PiHole läuft eine fixe IP Adresse.

Okay, I will try. Mache ich morgen und dann gebe ich Rückmeldung.
Danke bis dahin!

Ich habe die feste IP-Adresse mit netplan eingerichtet. Die Datei /etc/netplan/50-cloud-init.yaml hat jetzt folgenden Inhalt:
network:
version: 2
renderer: networkd
ethernets:
enp1s0:
addresses:
- 192.168.178.121/24
dhcp4: no
gateway4: 192.168.178.1
nameservers:
addresses: [192.168.178.1]
Anschließend mit “netplan apply” scharf geschaltet und den Rechner neu gestartet. Leider wieder keine DNS-Auflösung nach dem Neustart! Ich musste wieder pihole -r ausführen um ins Internet zu kommen.
Oder muss ich die feste IP-Adresse ganz anders einstellen? Oder liegt die Ursache für mein Problem doch noch ganz woanders?

Hey,
ich habe auf meinem Heimserver exakt das gleiche Problem unter Ubuntu 18.04.2 mit Pi-hole v4.2.2.
Der Status ist dann immer folgender:

pihole status
  [x] DNS service is not running
  [✓] Pi-hole blocking is Enabled

Nach jedem Neustart muss ich pihole -r ausführen.
Vorher muss ich jedoch immer in der Datei Datei /etc/resolv.conf von

nameserver localhost

auf

nameserver 192.168.178.1

also den lokalen Router ändern, da sonst bei Pihole die Updateprüfung ins Leere läuft.

Unter Ubuntu 16 trat dieses Problem nicht auf, hat jemand eine Idee?

Die Lösung für mich war es offensichtlich, da pihole nun inzwischen wohl eine eigene Version dnsmasq mitbringt, die separat vorhandene systemweite Installation von dnsmasq zu entfernen.

Leider ist die Lösung von urfin keine Lösung für mein Problem, denn dnsmasq ist auf meinem Server nicht installiert. Und wenn ich mich recht erinnere, ist dnsmasq standardmäßig auf dem Ubuntu 18.04x-Server nicht installiert, jedenfalls kann ich mich nicht erinnern, es bewusst deinstalliert zu haben.
Hoffentlich hat noch jemand eine andere Idee??