Kein FTP-Server seit Pi-Hole Installation

Hallo!

Beobachtetes und erwartetes Verhalten

Ich habe einen FTP_Server (vsftpd) mit Ubuntu Server 24.04 aufgesetzt. Dieser funktionierte auch. Ich konnte ihn aus dem Internet mit z.B. Filezilla erreichen. Im Anschluß habe ich Pi-Hole installiert. Es war zwar aktiv, aber nicht als DNS im Router eingetragen. Ich hatte weiterhin Zugriff auf den Fileserver. Dann habe ich die DNS aktiviert und nun filtert Pi-Hole einwandfrei, aber mein FTP Server ist nicht mehr erreichbar.

Debug Token:

(https://tricorder.pi-hole.net/l1R7a74X/)

Vielen Dank, Nikolas

Möglicherweise blockt Pi-hole den Zugriff auf die Domäne Deines FTP-Servers.

Über Tools | Search Adlists lässt sich ggf. herausfinden, welche Blockliste(n) die Blockade zu verantworten haben.

Über Domains lässt sich die entsprechende Domäne von der Filterung ausnehmen.

Danke für die Antwort.
Ich habe jetzt erstmal den Pi mit Pi-Hole aktiviert und setze den Server nochmal neu auf. Wenn ich Resultate habe, melde ich mich.
Es liegt aber nicht an lighttpd für das Web-Interface?
Pi-Hole sowie der FTP-Server laufen auf einem Rechner über die gleiche IP.
Nicht das da ein Konflikt liegt. Ich hatte nämlich die Domain unter Pi-Hole freigegeben. Allerdings habe ich nur einen Eintrag gefunden (Über den Query-Log). Es handelte sich um einen AAAA Eintrag.
Schöne Pfingsten.

So habe alles neu aufgesetzt. Wieder das gleiche. Nach einem Reboot und aktivem Pi-Hole keinen Zugriff mehr auf den FTP-Server.
Status: Verbinde mit [2002:xxxx:39f6:xxxx:3a10:xxxx:fea4:xxxx]:21... Status: Verbindungsversuch fehlgeschlagen mit "ECONNREFUSED - Verbindung durch Server verweigert". Fehler: Herstellen der Verbindung zum Server fehlgeschlagen
Kann es doch daran liegen, dass Pi-Hole und FTP-Server die gleiche lokale IP verwenden?
Ich habe nach der Domain gesucht und keinen Eintrag gefunden. Pi-Hole läuft Bonestock, ich habe nur die Standart Adlist installiert.

FTP, DNS und HTTP sind unterschiedliche Protokolle und können problemlos über dieselbe IP-Adresse bereitgestellt werden.

Pi-holes DNS ist hier auch nicht involviert, da Deine Fehlermeldung bereits eine aufgelöste IP zeigt.
(Nebenbei: Die Meldung zeigt eine öffentliche IPv6. Als unsicheres Protokoll würde ich FTP für den Zugriff über öffentliche Netzwerke eher vermeiden).

UFW ist installiert und läuft. Der Zugriff auf den Server ist SSL verschlüsselt. Aber solange ich dieses sonderbare Problem nicht gelöst habe kommt der nicht dauerhaft ans Netz.

Toll ist, dass ich die IP-Geschichte jetzt schonmal als Fehlerquelle ausschließen kann. Danke dafür.

Zurück zum Fehler: Sobald ich Pihole installiere und im Anschluss den FTP server läuft alles. Erst wenn ich die lokale DNS auf Pihole ändere funktioniert es nicht mehr. Da Pihole nur mit der standart Adlist läuft wird die Domain auch nicht geblockt. Auch ein deaktivieren des Pihole Services bringt keine Änderung. Ich würde mich wirklich sehr freuen, wenn der Rechner läuft.

So, habe alles nochmal mit Ruhe gemacht. Es lag an Pi-Hole. Ich hatte so viele Adlists installiert, dass der Server dadurch geblockt wurde. Ich habe Pi-Hole sorgfältiger gefüttert und nun läuft alles.

Vielen Dank für die Hilfe und frohe Pfingsten! :raising_hand_man: