Kein apt-get update mehr möglich

Guten Abend,

seit dem Update auf die Version 5 ist auf meinem RaspberryPi das Ausführen von "apt-get update" ohne Fehlermeldung nicht mehr möglich.

Hier bekomme ich folgende Fehlermeldung:

pi@raspberrypi:~ $ sudo apt-get update
Fehl:1 https://download.docker.com/linux/raspbian buster InRelease
Temporärer Fehlschlag beim Auflösen von »download.docker.com«
Fehl:2 http://archive.raspberrypi.org/debian buster InRelease
Temporärer Fehlschlag beim Auflösen von »archive.raspberrypi.org«
Fehl:3 http://raspbian.raspberrypi.org/raspbian buster InRelease
Temporärer Fehlschlag beim Auflösen von »raspbian.raspberrypi.org«
Paketlisten werden gelesen... Fertig
W: Fehlschlag beim Holen von http://raspbian.raspberrypi.org/raspbian/dists/buster/InRelease Temporärer Fehlschlag beim Auflösen von »raspbian.raspberrypi.org«
W: Fehlschlag beim Holen von https://download.docker.com/linux/raspbian/dists/buster/InRelease Temporärer Fehlschlag beim Auflösen von »download.docker.com«
W: Fehlschlag beim Holen von http://archive.raspberrypi.org/debian/dists/buster/InRelease Temporärer Fehlschlag beim Auflösen von »archive.raspberrypi.org«
W: Einige Indexdateien konnten nicht heruntergeladen werden. Sie wurden ignoriert oder alte an ihrer Stelle benutzt.

PiHole läuft als Dockercontainer und beim Starten dieses Containers erhalte ich folgenden Fehler:

[i] Number of gravity domains: 4916310 (4254607 unique domains)
[i] Number of exact blacklisted domains: 0
[i] Number of regex blacklist filters: 0
[i] Number of exact whitelisted domains: 8
[i] Number of regex whitelist filters: 0
[i] Cleaning up stray matter...
[✓] Cleaning up stray matter
[✗] DNS service is NOT listening
kill: usage: kill [-s sigspec | -n signum | -sigspec] pid | jobspec ... or kill -l [sigspec]
Pi-hole version is v5.3.1 (Latest: v5.3.1)
AdminLTE version is v5.5 (Latest: v5.5)
FTL version is v5.8 (Latest: v5.8.1)
[cont-init.d] 20-start.sh: exited 0.
[cont-init.d] done.
[services.d] starting services
Starting crond
Starting lighttpd
Starting pihole-FTL (no-daemon) as root
[services.d] done.

Abgesehen von dem DNS Fehler und denn fehlenden Updatelisten funktioniert PiHole aber ohne Probleme..
Was tun? :cold_sweat:

Nur um sicherzugehen:
Gemeint ist hier die Ausführung auf dem Docker-Host - und nicht innerhalb des Pi-hole-Containers, oder?

Letzeres würde nämlich keinen Sinn machen, da Pi-hole-Updates ausschließlich über ein neues Image erfolgen sollten.

Für Deinen Docker-Host solltest Du prüfen, dass dieser zumindest einen öffentlichen DNS-Server Deiner Wahl verwendet.

Die aktuell konfigurierten DNS-Server sieht man in einem Raspberry Pi OS standardmässig mit:

cat /etc/resolv.conf

Was gibt das auf Deinem RPi (auf dem Pi-hole in Docker läuft) zurück?

Das Update habe ich schon vor ein paar Wochen über einen neuen Docker-Container ausgeführt.
Mein Problem ist, dass ich seit diesem keine Updates mehr auf meinem OS selbst ausführen kann, geschweige denn eine Verbindung über den Pi-Browser im Internet bekomme.
Ich vermute stark, dass das mit dem PiHole irgendwie zusammenhängen muss...

Die Ausgabe aus dem Commannd ist folgende:

pi@raspberrypi:~ $ cat /etc/resolv.conf
# Generated by resolvconf
domain fritz.box
nameserver 192.168.178.100

Dateien meiner Configs hängen anbei,

Unbenannt
Unbenannt2
Unbenannt3
Unbenannt5

Wie sieht denn dhcpcd.conf auf Deinem RPi aus?

grep -v '^#\|^$' /etc/dhcpcd.conf

Als kurzfristige Massnahme könntest Du Deine /etc/resolv.conf editieren und die letzte Zeile darin auf nameserver 8.8.8.8 ändern.
Danach sollte ein apt-get update zunächst wieder funktionieren.

Allerdings erklärt das noch nicht:

Bist Du sicher, dass Pi-hole überhaupt DNS-Anfragen beantwortet?

Bitte lade ein Debug Log hoch und poste hier anschliessend nur das Token.
Das Token generierst Du über

pihole -d

wobei Du die Frage nach dem Upload bejahst, oder Du machst das über die Weboberfläche:
Tools > Generate Debug Log

Wie sieht denn dhcpcd.conf auf Deinem RPi aus?

Im LXTerminal mit dem Command:
pi@raspberrypi:~ $ sudo grep -v '^#|^$' /etc/dhcpcd.conf
hostname
clientid
persistent
option rapid_commit
option domain_name_servers, domain_name, domain_search, host_name
option classless_static_routes
option interface_mtu
require dhcp_server_identifier
slaac private

Der Token ist folgender:

https://tricorder.pi-hole.net/ltmdpidrfm

Dein Debug Log zeigt, dass es auf Deinem RPi eine größere Zeitabweichung gegeben hat
(1622970300 = 06.10. 11:05 gegenüber 1623335100 = 10.10. 04:25):

*** [ DIAGNOSING ]: contents of /var/log
-rw-r--r-- 1 pihole pihole 61358 Jun 10 16:25 /var/log/pihole-FTL.log

   -----tail of pihole-FTL.log------
   [2021-06-10 16:24:58.826 2395M] WARN: getOverTimeID(1623335100): 608 is too large: 1622970300

Das würde auch die (mittlerweile von Dir herauseditierten) Fehlermeldungen erklären:

http://raspbian.raspberrypi.org/raspbian/dists/buster/InRelease is not valid yet (invalid for another 3 d 1 h 27 min 4 s). Updates for this repository will not be applied.

Vielen Dank für deine Antwort. Nach einem Systemreboot hat sich der RPi wieder gefangen und ich konnte die Paketlisten updaten. Wie das passieren konnte ist mir allerdings schleierhaft.

Leider besteht das Problem mit dem DNS-Service noch .__.