It Just doesn't seem to work


#1

Hi

I’ve installed everything, and set it up as per the instructions on the pi hole page, also checking the guide on adafruit, but it doesn’t seem to be blocking many, or any adverts. I’ve set the DNS settings on my pc (wired connection) and ipad and iphone (wireless) to no avail, I still seem to be getting adverts when I look on test pages.

Eventually I’d also like to get it working on my elderly parents ipads/laptops as well as they are both getting VERY frustrated with adverts.

Any help would be grately appreciated.


#2

You can test connectivity by doing below DNS lookup on a Windows, Linux or Mac client PC:

nslookup pi.hole <PIHOLE_IP_ADDRESS>

And you can test if a client is configured properly with below one if you leave out the “<PIHOLE_IP_ADDRESS>” bit.
Results should resemble above nslookup:

nslookup pi.hole

If they dont resemble, you configured something wrong somewhere:

And if your router is lacking settings described in above FAQ:

Below an example on one of my client PC’s with 10.0.0.1 being my router and 10.0.0.2 being Pi-hole:

C:\>nslookup pi.hole 10.0.0.2
Server:  noads.dehakkelaar.nl
Address:  10.0.0.2

Name:    pi.hole
Address:  10.0.0.2

C:\>nslookup pi.hole
Server:  noads.dehakkelaar.nl
Address:  10.0.0.2

Name:    pi.hole
Address:  10.0.0.2

C:\>ipconfig /all

Ethernet adapter Local Area Connection:

   DHCP Enabled. . . . . . . . . . . : Yes
   Autoconfiguration Enabled . . . . : Yes
   IPv4 Address. . . . . . . . . . . : 10.0.0.11(Preferred)
   Subnet Mask . . . . . . . . . . . : 255.255.255.0
   Lease Obtained. . . . . . . . . . : woensdag 21 maart 2018 16:45:05
   Lease Expires . . . . . . . . . . : donderdag 22 maart 2018 16:45:05
   Default Gateway . . . . . . . . . : 10.0.0.1
   DHCP Server . . . . . . . . . . . : 10.0.0.2
   DNS Servers . . . . . . . . . . . : 10.0.0.2

#3

Please send us the token generated by

pihole -d

so we can help debug the issue.


#4

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.