Issues with blocking ads

Expected Behaviour:

I expect the links I give it to block the sites

Actual Behaviour:

I have given my pi-hole about 5 million domains to block to try it out. It seems that it either ignores the gravity or it could be a configuration issue on my part. Below is my compose.yml

# More info at and
    container_name: pihole
    image: pihole/pihole:latest
      - "53:53/tcp"
      - "53:53/udp"
      - "67:67/udp" # Only required if you are using Pi-hole as your DHCP server
      - "9080:80/tcp"
      TZ: 'Europe/Stockholm'
      - './etc-pihole:/etc/pihole'
      - './etc-dnsmasq.d:/etc/dnsmasq.d'
      - ''
      - ''
      - NET_ADMIN # Required if you are using Pi-hole as your DHCP server, else not needed
    restart: unless-stopped

Any and all help is appreciated. Thank you

Debug Token:

here are some screenshot of what i am referring to:

The culprit is this regex whitelist entry


You have a similar blacklist entry (which is disabled) for


Although the intent was to whitelist this domain, using AdBlock Plus style syntax, as a regex this actually matches everything and anything. And since whitelists always have priority, this single rule is whitelisting all domains.

Delete these two rules and test again. You should find the 1717... domain is now blocked.

To add those two domains back correctly, go to Domains > Domain, enter and tick the box Add domain as wildcard. Click Add to Whitelist. Repeat for and click Add to Blacklist.

oh wow. thank you. i will test this immediately

Thank you so much. this had been driving me crazy for days

1 Like

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.