Issues using IPv6 after installing Pihole

Please follow the below template, it will help us to help you!

Expected Behaviour:

Connecting to other servers over IPv6 shouldn’t fail.

Actual Behaviour:

Can’t seem to make any outgoing connections over IPv6. Incoming connections appear to work.

Debug Token:

Your debug token is: https://tricorder.pi-hole.net/09ovhzq739

After installing Pihole on my VPS, IPv6 doesn’t work correctly anymore. I can’t seem to connect to other servers over IPv6. Domains are resolving correctly, but it just hangs while trying to connect. I’m not really sure what may have gone wrong, but every time I restore from a server backup and try running the Pihole installation script again, I run into the same issue.

Interestingly, running the command “ip -6 address ls | grep inet | grep global” used to give my public IPv6 address, but now it returns some weird address that I’ve never seen before. I believe this may be the problem but I’m not sure what to do to fix it.

I’ll include the output of “ip -6 addr” at the end of this post in case it gives any hints. I was hoping I could get some assistance in fixing this if any of you have an idea about what may have gone wrong.

Thanks.

root@Testmachine:~# ip -6 addr
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 state UNKNOWN qlen 1000
    inet6 ::1/128 scope host 
       valid_lft forever preferred_lft forever
2: dummy0: <BROADCAST,NOARP,UP,LOWER_UP> mtu 1500 state UNKNOWN qlen 1000
    inet6 fe80"I think this is a private address."/64 scope link 
       valid_lft forever preferred_lft forever
3: eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 state UP qlen 1000
    inet6 2600:"Weird address that I've never seen"/64 scope global mngtmpaddr noprefixroute dynamic 
       valid_lft 2591998sec preferred_lft 604798sec
    inet6 "Only the end of my actual IPv6 address"/64 scope link 
       valid_lft forever preferred_lft forever

The fe80 is a local only address that stays on the LAN. The 2600 is a globally unique address that is being assigned by a router or your ISP dynamically. You have an address ending in 8014 that is the active address, but you have set up the Pi-hole and some other services to bind to an IPv6 that ends in 7308. Check with your VPS provider to see what is the correct IPv6 address and set the servers to use that IP address.

1 Like
The address that ends in 7308 is my real address. I'm not sure where it's getting the one ending in 8014. I tried editing my network/interfaces file to specify the correct address, but that didn't help. I may have the syntax wrong. I had to Google it to find some examples.

If you have a minute, could you tell me if this looks right?

auto lo
iface lo inet loopback

auto eth0
allow-hotplug eth0

iface eth0 inet static
    address IPv4Address/24
    gateway 23.92.20.1
    up   ip addr add SecondaryAddress/24 dev eth0 label eth0:1
    down ip addr del SecondaryAddress/24 dev eth0 label eth0:1

iface lo0 inet6 loopback
iface eth0 inet6 static
  address IPv6Address
  netmask 64
  gateway fe80::1

You’ll have to verify the network configuration with your provider, the 8014 is being assigned dynamically so there is some mechanism on their network that is configuring the server for that address.

1 Like