"Internet evtl. nicht verfügbar" UN, Connect Box


#1

Setup:
UM, Connect Box

  • IPv4 DHCP deaktiviert
  • IPv6 Stateful aktiviert, 512 Adressen

Raspberry Pi 3

  • Raspbian, aktuellster Stand
  • pi-hole v4/v4/v4
  • lease time: 0
  • DHCPv6: deaktiviert

-> Blocklisten: Werkseinstellungen

Hallo,

bei den Smartphones meint es nach dem sie sich per wlan verbunden haben: “Internet evtl. nicht verfügbar”. (Google Pixel 2 XL, Android 9, Sicherheitsupdates 5. Oktober 2018/Samsung Galaxy A3 2016, Android 7).

Hatte Testweise auch schon den Router als DNS Server beim pi-hole eingetragen, hatte kurz (2 Tage) zu Besserung geführt, nun macht es wieder die genannten Probleme.

Frage: was für Einstellungen am besten vornehmen? Bzw. evtl. auch komplett neu aufsetzen? (Hatte Probleme von V3.x auf V4 zu kommen, wollte mir immer wieder die Adresse für das Update nicht auflösen was bei der Installation zu Problemen geführt hatte, bzw. beim Update hatte es dann auch immer wieder Einstellungen verworfen)

Grüße


#2

Servus

ich habe das gleiche Phänomen, das ich im eigenen Netzwerk über OpenVPN verbunden nicht ins Internet komme und das Mobile Phone mir diese Meldung ausgibt.

Connecte ich über den Unitymedia Wifispot oder Mobiles Datennetz via OpenVPN, funktioniert alles einwandfrei.

Woran das liegt ist mir nicht schlüssig, und ob das so richtig ist und nicht anders geht, weil technisch evtl. nicht durchführbar… ein Rätsel

Wäre toll, wenn hier weitergeholfen werden könnte
Vielen Dank


#3

Hi,

also ich probiere auch seit wenigen Tagen mit dem PiHole und der ConnectBox herum… Hatte auch das Problem, dass ich mit meinem iPhone keinerlei Internetseiten mehr aufrufen konnte.
Zunaechst aber einmal zu den Einstellungen:

Ich habe anfangs ebenfalls die IPv4 DHCP Option deaktiviert und IPv6 auf Stateful belassen. Auf dem PiHole habe ich in den Settings den DHCP-Server aktiviert, sowohl für IPv4 als auch für IPv6. Nach einen Neustart der Internetverbindung auf dem jeweiligen Endgerät hat auch soweit alles funktioniert… für etwa 2 Stunden… Danach bestand zwar weiterhin die WLAN-Verbindung, aber ich konnte auf keine Internetseiten zugreifen und auch die PiHole Weboberfläche war von dem Gerät nicht mehr zu erreichen und auch die Oberfläche der Connectbox war nicht zu erreichen. Mit einem anderen Gerät kam ich noch auf die Oberfläche der Connectbox und habe einfach mal die IPv4 DHCP Option wieder aktiviert. Anschließend haben die Geräte noch immer ihre IP-Adresse über das PiHole zugewiesen bekommen und die Queries wurden zum Teil geblockt. Und auch nach 12 Stunden war die PiHole Weboberfläche zu erreichen und die Anfragen wurden geblockt. Ob das so bleibt, wird die Zeit zeigen. Das generelle Problem mit den ConnectBoxen und dem PiHole scheint bekannt, aber wenig behandelt zu sein. Zumindest ergab das meine Recherche.


#4

Hallo,

folgende Einstellungen müsst ihr vornehmen, damit das ganze problemlos mit der Connect Box funktioniert:

1.) DHCP im Pi Hole aktivieren.
2.) In der Connect Box gehst du auf “Erweiterte Einstellungen” ~> DHCP.
3.) ipv4 lässt sich problemlos deaktivieren, ipv6 allerdings nicht.
Den DHCP6 Server stellst du auf “stateful”
Unter “Anzahl der Adressen” kommt eine “1” rein.
Danach die Einstellungen übernehmen, Connect Box neustarten und alles funktioniert.
Werbung über ipv4 als auch ipv6 wird geblockt.

Pi-Hole ist dann der DHCP Server und verteilt die IP-Adressen im Netzwerk.

Klappte bei mir so ohne Probleme und alles läuft einwandfrei.

Beste Grüße


#5

Danke Dir fuer die Rueckmeldung, Boedefeld1990. Allerdings ist mir aufgefallen, dass wenn ich IPv4 in der ConnectBox ausstelle, ich nach kurzer Zeit (ca. 1-2 Std.) keine Verbindung mehr mit den Endgeräten ins Netz aufbauen kann und auch die Weboberfläche vom Pi nicht mehr erreichen kann?
Allerdings war die Anzahl der Adresse unter IPv6 noch auf 512, werde es mal mit der 1 versuchen.
Und nun mit (wieder) aktivierter IPv4 DHCP Option habe ich nach 12 Stunden das Problem, dass scheinbar keine Queries mehr über den PiHole laufen.


#6

Die Probleme hatte ich auch anfangs.
Konnte nach wenigen Stunden das Webinterface nicht mehr aufrufen.
Sonntagabend kam allerdings ein Update für Pi-, Hole heraus (Vers.4.1) mit dem das Problem behoben wurde.
Seitdem habe ich keinerlei Probleme mehr mit dem Webinterface.
Laut changelog gab es Probleme mit lighttpd welches immer abstürzte und man dadurch das Webinterface nicht mehr aufrufen konnte.
Also am besten Pi-Hole updaten falls Du es noch nicht getan hast.
Die Anzahl der Adressen unter IPv6 muss zwingend auf auf 1 stehen.
Ansonsten blockt Pi-Hole nichts.

Gruß


#7

Also Pi-Hole wurde upgedated und die Einstellungen genau so, wie von Dir beschrieben eingerichtet. Laeuft leider immer noch nicht, wie es soll. Anfangs funktioniert es tadellos, doch spätestens am nächsten Tag habe ich zwar noch eine Verbindung zum Router aufbauen können und auch auf dem Webinterface vom Router zugreifen können, aber weder das Pi-Hole Webinterface ist erreichbar, noch kann ich irgendeine Internetseite aufrufen. (Whatsapp-Nachrichten bspw. gehen aber durch) Ich hasse diese ConnectBox.


#8

Besten Dank für die Hinweise.
Damit war es ein Kinderspiel.