Installation on a VM always selecting wrong ethernet interface

Please follow the below template, it will help us to help you!

Expected Behaviour:

I want to install Pi-hole on my ex: ens37 ethernet interface . It should be on my ex: address

Actual Behaviour:

When its time to select the interface even if there is the little start beside (*) the ens37 it install it with on the ens33 with an ip of and give me the admin page on the other interface . but it even say that is installed on interface ens37 but with the ip address of ens33

I tried it like 4-5 time dunno whats seems to be the problem

Can you try installing it again on the VM and then, when it's done, create a debug log and post the URL it gives you. This will show how your interfaces are set up straight after such an install. To create and upload automatically the command is

pihole -d -a

and the token URL is given at the end to post here.

debug token:

AH never mind it worked , just because in the script the address showed for login page was as it was like ens33 but when i typed the address of the ens37 interface it worked. lol

Your debug log shows ens37 is being used:

*** [ DIAGNOSING ]: Setup variables
*** [ DIAGNOSING ]: Networking
[✓] IPv4 address(es) bound to the ens37 interface:

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.