Install just stops after checking for dependencies - anyone help please?


I've just setup a fresh install of a Pi with the latest NOOBS / Raspbian as of today. Formatted the SD card, latest NOOBS 2.0.0 and no other software installed.

I've run the Pi-Hole install script as root, all goes well until it just stops. No error, I'm just back at the command prompt.

::: You are root.
::: Verifying free disk space...
::: Checking apt-get for upgraded packages.... done!
::: Your system is up to date! Continuing with Pi-hole installation...
:::    Checking for apt-utils... installed!
:::    Checking for whiptail... installed!
:::    Checking for git... installed!
:::    Checking for dhcpcd5... installed!
:::    Checking for dnsutils...root@raspberrypi:/home/pi#

Anyone suggest what I might be doing wrong? Without any visible error(s) I'm a bit stuck. Also tried the curl method shown on the Pi-Hole homepage - exactly the same thing happens.



UPDATE: As the script seemed to be ending on 'Checking for dnsutils' I tried to manually install them with sudo apt-get install dnsutils And got this:

The following NEW packages will be installed:
0 upgraded, 1 newly installed, 0 to remove and 0 not upgraded.
Need to get 113 kB of archives.
After this operation, 325 kB of additional disk space will be used.
Err jessie/main dnsutils armhf 1:9.9.5.dfsg-9+deb8u6
  404  Not Found [IP: 2001:41c9:1:3ce::11 80]
E: Failed to fetch  404  Not Found [IP: 2001:41c9:1:3ce::11 80]

E: Unable to fetch some archives, maybe run apt-get update or try with --fix-missing?

A clear 404 when attempting to install dnsutils. So I did as suggested and ran a sudo apt-get update and then tried installing dnsutils again - worked. fine this time.

Seems like the Pi-Hole script isn't handling failures to apt-get-install packages very gracefully? Certainly in my case there was nothing written to the console which gave any clues as to what was failing - I was just dropped back to the command prompt.

Anyway progressed nicely after that hiccup and I'm up and running.


That's my fault, the trap is only written to catch the failure to update apt index, the actual error doesn't bubble up to the user. Need to get that second half of a trap to display but apt really should behave and follow our update call earlier in the script.

It's annoying to us and to the user, but when we just code as volunteers on free time, we either get functions out or sit and wait till they're perfect and no one gets any updates for months...

No problem at all - the script worked flawlessly after the dnsutils hiccup. Excellent job!


I am having the same exact problem except it stops while checking for iproute2. I have tried installing the package manually but it is already installed. I removed the package and reinstalled it but that still didn't fix the problem. Is there anything else that could be causing the script to stop while checking the dependencies?

Can you paste a copy of the terminal output when the script stops running? The iproute2 package is different depending on the distribution version.

I tried reinstalling Raspbian but I'm still having the same problem.

I recently had similar problem durring the installation of pi-hole on Raspbian Jessie Light, and found that you need to run:
sudo apt-get update BEFORE the installation of pi-hole
sudo apt-get upgrade AFTER the installation of pihole

According to a document I found the difference is:
Updates the list of available packages and their versions, but it does not install or
upgrade any packages.
Actually installs newer versions of the packages you have. After updating the lists, the
package manager knows about available updates for the software you have installed.

You can find my installation manual here.

This should be fixed in the next version. Are you running Wheezy by any chance?

Yes, I am running Wheezy

Had a similar problem when installing on Ubuntu 12.04. Upgraded to 16.04 LTS first, and did not have a problem there.

Try doing

apt-get update
apt-get install iproute

on Wheezy and then run through the installer again. Repeat for any other dependencies it fails out on.

1 Like