Ignoring query from non-local network

I have the same problem. pi-hole just updated to 5.8.1 and FTL to 5.13 and then this message arrived. My debug token is https://tricorder.pi-hole.net/axWfsoFq/

I followed the instructions for non_local_details and now the message contains
Ignoring UDP query from non-local network (logged only once)
which is rather puzzling as that address is most definitely local. I'm using the 'normal'

May I please have some help/words of advice. Thanks kindly.

1 Like

This is interesting, are there other queries from this host being accepted? This may point to a bug in the analysis of the dropped peer's address. This is still a feature undergoing testing.

At the moment (it's 1117am) the last time Pi-Hole shows any log for this device (via ) was at 0856am. Despite the fact that I've rebooted it and tried to use it (it's a roku-stick, wireless). The roku-stick appears to be working as normal.

I've uploaded an image of the log

Regards, Jeff

I should also add an image of the Dashboard where it shows that very little traffic seems to be going through the PiHole at the moment, and at previous times.

Dear ksflanvnifxa,
I seem to have posted into the middle of your post. I'm probably using this 'discourse' system all wrong. I humbly apologize if I upset you or confused anything you were trying to post.

I separated your posts into your own discussion.

Looking at your debug log, I see a few very odd things. Are you connected to your network with both Ethernet and WiFi at the same time?

Some very odd things are happening here, for instance, during the DHCP test you are getting DHCP requests made from one interface back on both, i.e. you requested two but received four offerings. Furthermore, your Pi-hole failed to resolve DNS correctly on both interfaces whereas everything was fine on the loopback interface.

Please ensure you are connected only with one device at a time to your network or very strange things may happen. This is not something unique to Pi-hole but you may experience malfunction or slowdowns with all other services on your machine, too.

Please allow me to mention that all was working fine until I did the upgrade. Nothing else in my network has changed except PiHole, It's running on a Raspberry Pi with eth0 at and wlan0 at I use wlan0 for SSH into the Raspberry PI.

Here's how I set the static IP's for eth0 & wlan0
interface eth0
static ip_address=
static routers=
static domain_name_servers= fd51:42f8:caae:d92e::1
static domain_search=

interface wlan0
static ip_address=
static routers=
static domain-name_servers= fd51:42f8:caae:d92e::1
static domain_name_servers=
static domain_search=

I can't think of anything else to tell you. Have I understood what you're asking? Are there any diagnostics I should run?

Is there some way to revert to the previous version of PiHole please?

Oh, and thankyou for splitting my query into a different thread.

Best Regards,

Reverting shouldn't be the solution, I don't think anything really changed in your direction. I still believe that the issue lies in being connected to the same network over two independent connections at the same time and this causing conflicts (some of which are visible in the debug output).

Could you try some other Interface settings from the settings page (DNS tab) of the Pi-hole dashboard? Does this solve your issue? Maybe Pi-hole gets confused because you have two interfaces for the same address/subnet. Having both enabled at the same time isn't a healthy setup - even when it worked before, there are no guarantees it will work in the future, e.g., if some networking drivers are updated.

Thankyou for your patient help.
If I change to 'Bind only to interface eth0' then the dashboard shows NaN in all the boxes at the top

If I set DNS to 'Respond only on interface eth0' Then the dashboard looks normal. But I do get
and the Pihole chronometer shows P-hole offline.

Best Regards,

No worries! I'm new here too and getting used to the conventions....

It's Monday and I'm back at work (as perhaps are you) and thus have less time to work on this but I wanted to let you know that I did deactivate the WiFi (via sudo ifconfig wlan0 down) and (as previously mentioned) set the PiHole DNS to 'Respond only on interface eth0'. The PiHole appears to be working from the GUI but the PiHole -Chronometer shows the PiHole to be offline.

I find it odd that PiHole is having trouble with there being two network interfaces given that it's running on a Raspberry Pi which comes with two network interfaces! (three if you include BlueTooth).

Best Regards,

This is a known bug and is being addressed:

I'd like to close this topic now with a thankyou to all who helped and an attempt at a summary.

PiHole is working again without generating that 'Ignoring query from non-local network' message. The modification pihole checkout ftl new/non_local_details was helpful in showing the IP address that generated the message. It was a wifi device on the same network as everything else!

I have, on my Raspberry Pi, both the Ethernet and Wifi connected to the same network. On the DNS tab of the Settings page I have changed from the default to Respond only on interface eth0. I temporarily disabled the WiFi (with sudo ifconfig wlan0 down) but that didn't seem to make any difference.

I am now awaiting the fix to PiHole -chronometer. If I was more impatient I would apply the fix, but I'll wait for the official fix to come through as part of the build (probably using the wrong terms as I know nothing about Github).

Thanks again

It's great to hear everything is now working for you as it should.

I'd recommend to run a

pihole checkout ftl master

now to get back on track, otherwise, you will be fixed to this special version and won't receive any updates in the future. They are only published on the master branch.

Actually, it's not odd at all. The entire system has problems, you may not have noticed them as many things can be automatically retried (possibly but not necessarily with some extra timeouts) but you just found a case where it actually matters. It only remains for me to say that this is not an issue that affects Pi-hole alone. It just happend to be the most complex network application on your Raspberry.

Thankyou again DL6ER. I've run the suggested pihole checkout ftl master


I am facing the same issue after updating to the latest version.
Just wanted to notify that last night I executed the command suggested above and this morning (around 10H later) facing the same issue.

Any suggestions would be appreciated.
Thank you in advance

This command isn't doing anything if your are not using a special branch. Please check out the other posts in carefully before running any possibly dangerous commands from the web.

Did you try


This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.