I get 400 Bad Request when I try to access PiHole admin

Expected Behaviour:

I installed PiHole on Ubuntu 22.04. I am trying to access the admin interface with http://<my_ip_addr>/admin, but I keep getting 400 Bad Request

Actual Behaviour:

Getting 400 Bad Request

Debug Token:


Your debug log shows a lot of messages like this:

[✗] udp: is in use by named (https://docs.pi-hole.net/main/prerequisites/#ports)
[✗] udp: is in use by named (https://docs.pi-hole.net/main/prerequisites/#ports)

This indicates there is another service (named in your case) using port 53.

You need to disable named.

Hey! I did that, it's still causing the same error: https://tricorder.pi-hole.net/cphy3AqX/, but with different errors

Now, you need to disable nginx (or change nginx to a different port).

Also, looks like you disabled named, but pihole_FTL didn't start. Please try to restart pihole-FTL using:

sudo service pihole-FTL start

Alright, so I disabled nginx, and started the pihole server but still getting bad request: https://tricorder.pi-hole.net/zxKifesC/

Nginx is still active:

[✗] tcp:*:80 is in use by nginx (https://docs.pi-hole.net/main/prerequisites/#ports)

Weird, I thought I disabled it. Let me try again

Disabled nginx altogether: https://tricorder.pi-hole.net/UswMyg7n/

OK, now we just need to restart lighttpd:

/sbin/lighttpd -f /etc/lighttpd/lighttpd.conf

Alright, the bad request error is gone, but I see just a could not reach page: https://tricorder.pi-hole.net/UKCLCYfA/

Also, thank you so much for patiently helping! I really appreciate it! :slightly_smiling_face:

What URL are you using to access?

Try this one:

Yes that's the one I'm using, just a blank page.

I also noticed your gravity.db file is empty.

You should try to repair the installation.
On the command line type pihole -r and select the "Repair" option.

Repaired, still getting blank page :frowning: https://tricorder.pi-hole.net/4KBoQJIm/

lighttpd is still not running properly.

*** [ DIAGNOSING ]: Pi-hole processes
[✗] lighttpd daemon is failed
[✓] pihole-FTL daemon is active

Try to restart your system to see if lighttpd comes up again.

Hello! I restarted lighttpd and reran the repair command: https://tricorder.pi-hole.net/XQ43A9Yd/

You now have two instances of lighttpd, one on port 80, another on port 8888:

*** [ DIAGNOSING ]: Ports in use
 [✓] tcp: is in use by lighttpd
     tcp: is in use by lighttpd
 [✓] tcp:[::]:80 is in use by lighttpd
     tcp:[::]:8888 is in use by lighttpd

What's the motivation for that?

Your last two debug logs both suggest that DNS requests don't make it to any of your Pi-hole host's IP addresses on any network interface.
I wonder about the many tunnel interfaces on that machine.
They seem to indicate an OpenVPN AS Server?
Is this a cloud-based installation?

*** [ DIAGNOSING ]: Name resolution (IPv4) using a random blocked domain and a known ad-serving domain
[✗] Failed to resolve  on lo (
[✗] Failed to resolve  on wlp2s0 (
[✗] Failed to resolve  on docker0 (
[✗] Failed to resolve  on as0t0 (
[✗] Failed to resolve  on as0t1 (
[✗] Failed to resolve  on as0t2 (
[✗] Failed to resolve  on as0t3 (
[✗] Failed to resolve  on as0t4 (
[✗] Failed to resolve  on as0t5 (
[✗] Failed to resolve  on as0t6 (
[✗] Failed to resolve  on as0t7 (
[✓] doubleclick.com is via a remote, public DNS server (

Please verify that your Pi-hole host system allows access to its required ports for its private range IP addresses.

Also, both of your debug logs show that your haven't configured any adlist for your Pi-hole:

*** [ DIAGNOSING ]: Groups
   id   enabled  name       date_added           date_modified        description
   ---  -------  ---------  -------------------  -------------------  -----------------
   0          1  Default    2022-11-16 16:48:10  2022-11-16 16:48:10  The default group

*** [ DIAGNOSING ]: Domainlist (0/1 = exact white-/blacklist, 2/3 = regex white-/blacklist)

*** [ DIAGNOSING ]: Clients

*** [ DIAGNOSING ]: Adlists

In its current state, Pi-hole wouldn't block any DNS request (if a DNS request would reach it).

Pi-hole would deploy a default adlist during installation (https://raw.githubusercontent.com/StevenBlack/hosts/master/hosts).

Did you remove that adlist by intention?

I stopped the lighttpd process at 8888, that was by mistake. https://tricorder.pi-hole.net/wCXGSjuA/

This is a physical machine, I'm also trying to set it up as an OpenVPN server.

I had configured PiHole to use the default adlist, I just ran pihole -r and reconfigured it.

You've cleared the second lighttpd instance: There's only one lighttpd now, listening on port 80.

However, DNS requests still don't make it to any of your Pi-hole host's IP addresses on any network interface:

I stopped the DNS server, looks like all required ports are present: https://tricorder.pi-hole.net/ey6oFLTe/
The DHCP ports are marked optional in the required ports link