Huawei P20 verliert sporadisch Internetverbindung

#1

Liebe pihole Community,

ich habe seit längerer Zeit folgendes Problem:

habe ein Netzwerk (AMPLIFI Router, 2.4ghz / 5ghz) mit mehreren Geräten in dem ein pihole in Verwendung ist, soweit so gut, keine Probleme.

Meine Freundin hat ein neues Smartphone huawei p20, mit dem gibts Probleme.
Das huawei verliert immer wieder die Internetverbindung, dies dauert mehrere Sekunden/Minuten, dann gehts wieder, kurz drauf, gibt es wieder Probleme mit der Verbindung. Mit den anderen Geräten gibts keine Probleme.

Statische IP
Smartphone Netzwerkeinstellungen zurückgesetzt
2ten pihole (pizero) getestet
Updates installiert
andere wlans ohne Probleme
Problem besteht nur wenn ein pihole hinterlegt ist

Im Gäste Wlan funktioniert das p20 ohne Probleme.
Wenn ich im bestehenden WLAN, das Pihole aus den dns herausgebe, ist alles wie es sein soll.

habe gestern noch auf einen pizero ein frisches pihole eingerichtet, auch da gibts dieses problem mit dem Internet Ausfällen.

Vielleicht kann mir wer helfen

lg

0 Likes

#2

Hatte ein ähnliches Problem im Zusammenhang mit IPv6.
Das USG hat den Clients den Netzwerk-Präfix von allen VLANs angeboten. Alle Clients im Netz kamen damit zurecht, ausser Android.
Falls bei Dir IPv6 aktiv ist, schau mal, ob Deine Clients mehrere Global Link Adressen haben. Falls ja, schau mal, ob die ersten 64bit gleich sind. Falls nicht, dürfte das Dein Problem sein.

0 Likes

#3

IPv6 ist nicht aktiv, ist mir ein Rätsel, muss ich wohl wirklich alles mal zurücksetzen.

0 Likes

#4

Wenn alle anderen Clients normal mit dem PiHole funktionieren, wird das Problem beim Android Gerät zu suchen sein.

Was kriegt das Android Gerät denn für eine IP Adresse, was für einen Gateway, welche DNS Adressen werden zugewiesen?
Diese Infos kannst Du Dir bsp. mit dieser App anzeigen lassen:

0 Likes