Https no-response issues

ubuntu
dnscrypt

#1

Expected Behaviour:

When I hit a particular https url, I expect the page to load. Unfortunately, due to pihole, it fails and says page not found.

Actual Behaviour:

Doing a more thorough analysis led me to this root cause.

> $ nmap --reason pointieststick.wordpress.com -p443 -Pn
> Starting Nmap 7.70 ( https://nmap.org ) at 2018-10-09 02:17 EDT
> Nmap scan report for pointieststick.wordpress.com (192.0.78.12)
> Host is up, received user-set.
> Other addresses for pointieststick.wordpress.com (not scanned): 192.0.78.13
> 
> PORT    STATE    SERVICE REASON
> 443/tcp filtered https   no-response
> 
> Nmap done: 1 IP address (1 host up) scanned in 2.08 seconds
> [xxx@yyy-xxx ~]$ nmap --reason github.com -p443 -Pn
> Starting Nmap 7.70 ( https://nmap.org ) at 2018-10-09 02:17 EDT
> Nmap scan report for github.com (192.30.253.113)
> Host is up, received user-set.
> Other addresses for github.com (not scanned): 192.30.253.112
> rDNS record for 192.30.253.113: lb-192-30-253-113-iad.github.com
> 
> PORT    STATE    SERVICE REASON
> 443/tcp filtered https   no-response
> 
> Nmap done: 1 IP address (1 host up) scanned in 2.09 seconds

I get back a ‘No-response’ from the sites in question. Is there a way to fix this ? Reverting back to the original list also doesn’t help. This is rendering my pihole pretty much useless :frowning:

Debug Token: leqeyxss3h

PS

I’m using dnscrypt2 with pi-hole and running this on a Ubuntu 18.04 machine. Not sure if this info is relevant, but throwing it out there. Tried without dnscrypt also and it didn’t help
_


#5

This post may have some additional information:


#6

There doesn’t seem to be anything specific in there. I have already applied those firewall rules too, but they didn’t make a difference :frowning:


#7

I ended up getting to the root cause of the issue and fixing it by turning off DNSSEC in the pihole DNS settings page in the Web UI. That finally cleared the issue for me.

Also, I was using PiHole as the DHCP server and ended up turning it off and using my router as the DHCP server


#9

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.