How to get hostnames to show up in web interface?

#1

Please follow the below template, it will help us to help you!

Expected Behaviour:

I am using my router DHCP and trying to get hostnames to show up in web interface. If no hostnames, then at least IP address. I only get router IP. No other device IP’s or host names show up. I have edited the /etc/hosts file to add the IP like this:
192.168.x.x. TV
and still I do not see IP or host name in the dashboard. It only shows the router IP. The router IP updates with new queries rather than other IP address’s showing up.

Actual Behaviour:

No device IP’s or host names show up in dashboard. Only router shows up. And the graphs in the dashboard are displaying nothing.

Debug Token:

hum01u5ifr!

#2

This means your routers tells the client via DHCP that it itself is the DNS server. It hence receives all queries and forwards them to your Pi-hole. This, in turn, replies to the router (because this is the device that asked the Pi-hole) which then sends the reply back to your devices.

Unfortunately, when routers do it this way, there is no chance to get the individual IPs on the Pi-hole as this information is not available if the router is acting as a proxy.

Check if you can set the Pi-hole’s IP address in your router’s DHCP setting rather than the DNS settings. If this is not possible, then you have to switch to Pi-hole’s internal DHCP server to be able to achieve what you want.