How to configure router so Pi-Hole protects whole network


#1

Sorry for this simple question but not sure if this is the right place i would set my router to use my pi for dns

Someone please confirm ?
See screenshot


#2

This may help.


#3

No, you should look for DHCP Settings or DNS server. The gateway is not the correct setting as it’s meant to be a way in and out of your private network.


#4

Seems dhpc settings not in my router
For dns I have this


#5

Change the setting for “DNS Server” to manual or whatever the option is (you don’t want Obtain DNS Servers Automatically).

Then enter the static IP of your Pi-Hole in the first set of blocks. Sometimes (not with all routers), the software requires an entry in the second set of boxes. If that is your case, enter the static IP of the Pi-Hole in those boxes as well.

Save changes, restart the router, renew the DHCP lease on your devices (this will give them the new DNS address of the Pi-Hole). You may have to clear DNS caches on connected clients, depending on the clients).


#6

Thanks for your reply

Here is issue .

If i leave second set of boxes empty i get error .

If i put same pihole ip i get error
If i put in second set of boxes the isp dns ip and in first set of boxes pihole ip i also get error

If i put a local ip in second set of boxes I also get error


#7

If that is an ISP-supplied router, you might be limited in your configuration options.

Do you have an option to turn off DHCP on that router? If so, you might be able to use the Pi-Hole DHCP to bypass the DNS settings on your router. Maybe.


#8

I wonder if dmz setting does same ?


#9

DMZ is a different setting and typically not something you want to use. This opens up one of your private IP addresses to the internet. Note the “advanced users” in the description.


#10

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.