How to configure my D-LINK DSL-225 DHCP Server?


#1

Hello,

I read the few topics on that subject but it seems every router is different with that.
I can’t understand how should I configure mine.

Here is what the LAN section looks like:

The 10.0.0.6 static IP is the Pi-Hole.
I can also disable the DHCP server but then how does the router know to use the Pi-Hole ?

Thanks a lot for the help !

Edit: Title typo


#2

Looks like your not able to assign LAN DNS servers via DHCP with this router.
Alternative is to disable the DHCP service on the router and instead activate the one from Pi-hole:

Ps. if you post router brand and model, someone else might confirm.


#3

Indeed seems to be the way to go.
I have a D-LINK DSL-225 (Not on their official website, it’s a model given by my ISP in Israel).

It allows very little customisation in general, I was already thinking about buying a new router before :stuck_out_tongue:

Will go the way of Pi Hole as DHCP server, however how the router will know that the Pi-Hole is DHCP server ?


#4

The router doesnt need to know.
The router just routes network packets from LAN to WAN (the internet) without caring who they are from.
After you switched DHCP server, make sure the clients renew their DHCP lease by either disconnecting & reconnecting network or reboot them.

Ps. I adjusted subject a bit for others to find if you dont mind.


#5

See page 26 of this for DNS settings http://files.dlink.com.au/Products/DSL-G225/Manuals/DSL-G225_J1_Manual_v1.00(WW).pdf

I think you need to set you IP of the Pihole outside the DHCP Range. eg 10.0.0.100
Run pihole -r to Reconfigure and change the IP address.
Then go to the WAN IPv4 settings page 26 and select you Pihole IP as a static DNS IP address.


#6

Page 26 refers to the WAN settings for the router.
You could configure the router to use Pi-hole as upstream DNS resolver.
But this will break stats being displayed on the Pi-hole web dashboard as only the router requests will be displayed and you wont see proper stats for the clients.