How do I install Pi-hole on a Synology NAS?

Hi, thanks for the guide.

By using quoted command i get an error saying can't find folder /etc/locale.gen

Any suggestions?

This post is old, but to have it answered: You need to stop the Synology DNS Server package prior installing pi-hole. Also, when you stop the Synology DNS-Server, make sure that your router knows some other DNS server in the meantime, like, so the install script can resolve the download commands. After installing, configure the router's DNS lookup to the address of your Synology once again.

So I just came across this post - I have a DS413 and I have been able to get Debian Chroot installed....

I can ssh in
sudo su - works
I can start Chroot
I can connect to it (I do get the setlocale warning and the prompt changes)
but when I try apt-get update it tells me
illegal instruction

and I can't get any farther - and don't know enough about Debian to figure out why it doesn't work - maybe my diskstation isn't compatible? I'm running the latest DSM 6.1.5-15254

So the installation went fine, i runned it without any problems for over a month.
I now updated pi-hole to version 3.3 and dnsmasq fails to restart.
I get this message:

[FAIL] Restarting DNS forwarder and DHCP server: configuration syntax check failed!

I ran pihole -r and pihole -g without succes.
Then i followed this tutorial from the beginning and still get the same message.
Any idea?

Read: Pi-hole v3.3 Released: It's "Extra" Special

Long story short: fallback, it won’t work.

1 Like

Nice thanks!
Reverted back and works again

How did you revert back?
I am failing that on my DS-413j because the armhf-package of dnsmasq is incompatible with the armel-architecture of the 413j.

Hi, great tutorial! I (almost :p) managed to get PiHole working on my Synology DS216Play in one run. Had to scroll in the comments to find a fix to get FTL working but it does work now.

I do have one issue, PiHole is working. I can see ads are not showing but the thing is I don't see any entries in the PiHole log or dashboard. So it says no ads are blocked but i'm sure Pihole is blocking because i've tested multiple websites. How do I fix this?

I have the exact same problem. Did you manage to solve the problem? If so, how did you fix it?

Now I get the error: Could not resolve host:

I can't install locales

root@Diskstation:/# apt-get install locales
Reading package lists... Done
Building dependency tree... Done
Package locales is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source

E: Package 'locales' has no installation candidate

the version of dnsmask is not 2.76 you need to update it, but i don't know how to.
you can revert to a previous version Pi-hole v3.3 Released: It's "Extra" Special

Hello @bakman2

have you tried installing the FTL-DNS version on synology? i tried to update using:
echo "FTLDNS" | sudo tee /etc/pihole/ftlbranch
pihole checkout core FTLDNS
pihole checkout web FTLDNS

this only updated the pi-hole and web version. not the FTL version itself.


My issue was with my router setup. I followed the instructions here:

I know this thread is for Synology NAS but I am sure a lot of folks with Asustor, QNAP, etc. come here too. That being said, just wanted to inform anyone that I got Pi-Hole working on my Asustor AS7004T-i5. I detailed my steps at:

@ ASUSTOR Community Forum

1 Like

I reverted back but my logs are still not working, everything is empty including the stats. Anyone able to fix this or at update dnsmasq?
My debug code is gj4qzkp686 if any developers are able to help.

Why bother really? why not just install Pi-hole on the latest RP3 and connect it to your gateway?

Hi there.
Are this method working in DMS 6.2?
Thanks :wink:

PS: My NAS is Synology DS215j

Hello, I have a problem with setting up pi-hole on a chroot setup with Debian stretch.
I installed Debian according to the second half of this link:

Updated all packages and the installation works. The only thing is that when I try to setup pi hole I get a disk space error. I found out that the installer checks for a root volume which my installation does not seem to have.

So I need to know how to get this volume mounted. Hopefully somebody can help me.

I also tried the installation as described here:

And when I run the chroot $CHROOT /etc/init.d/ start in the script as described I do get the root volume. But the wheezy release is to old to install pi hole on. And the script is missing in the stretch release.

Thank you.

i have it running on a ds213j with a jessie chroot, needed some modifications mentioned in this thread:

solution was the following:

Dann wäre in der Datei /etc/init.d/pihole-FTL die Zeile


auszukommentieren und

su -s /bin/sh -c "/usr/bin/pihole-FTL" "$FTLUSER"



zu ändern.

Und dann noch einmal

sudo service pihole-FTL restart

installed it following this howto: