Guest WiFi network cannot see the PI-hole DNS

I have an older Apple Airport Extreme router which still works fine. One of the nice features of this router (and I guess almost all new routers) is that it allows 2 SSID, one that is my home network, and one for guests. I usually put a simpler WPA2 password on the guest network, so when people visit they can easily connect, rather that my long and random password. The router keeps these networks separated from each other, so guest cannot see the other devices on my home network. This also means they cannot access my NAS or printers. I believe they are also isolated from each other, so one guest cannot see another. I also put IoT on this network, since if they are hacked, they cannot penetrate my main network.

Anyway, I recently noticed that devices connected to Guest network do not work. The router has a different IP range for those devices, and lists the DNS as this new IP, so my guess is that these devices cannot see the Pi-hole DNS server. I cannot figure out a solution around this. I cannot add DNS to each device or to every guest. Also, I do not want to disable that features that keeps the host SSID an Guest SSIS separated (firewalled) from each other.

Any suggestions? Thanks

I have a similar setup.

Try a firmware update as those things, are set at router level.

My router allows the guests devices to see each other (if feature is enabled) and the guest devices are able to work with my Pi-hole(s) ips.

Make a firewall rules there send dns to main lan. I did that on my guest and IoT wlan.