Group Management - scheinbar ohne Funktion

Hallo,
ich betreibe pihole schon seit Jahren, zuerst direkt auf dem Raspberry Pi3b, seit ca. 2 Jahren unter Docker auf einem OMV-NAS (kleiner DELL Mini-PC). Das klappt auch alles ganz gut.

Nun bin ich auf ein Problem gestossen, bei dem ich nicht mehr weiter kommen:
Mein Landxcape LX812i Mähroboter hat genau am 07.05.24 um 02:26 Uhr die Verbindung zu seinem Server in der positec.cloud verloren (laut queries fragt er nach "cmd-eu-prod.iot.public.positec.cloud" an). Der Robi ist per WLAN angebunden und ist laut der Fritz!Box auch verbunden. Im Log des Robi (kann man per USB ziehen) steht:
#12305 - 07/05/2024 02:26:47 - [wifi] - mqtt network failed
und
#12315 - 07/05/2024 02:26:11 - [wifi] - Mqtt Connection Lost!
Ich habe erst den Fehler am WLAN oder am Robi selbst gesucht. Dann habe ich in der Fritz!Box unter Heimnetz -> Netzwerk -> Netzwerkeinstellungen -> IPv4-Einstellungen unter Lokaler DNS-Server nicht die IP vom pi-hole, sondern die Fritz!Box selbst eingetragen (also Standardeinstellung). Nach dem Neuverbinden des Robis mit dem WLAN hat die Verbindung sofort funktioniert. Also das heisst vorher konnte ich mit der Landxcape App den Status etc. nicht abrufen, da er sich nicht bei seiner Cloud anmelden konnte. Wenn ich die pi-hole-DNS nun per DHCP nicht verteile, dann tritt das Problem nicht auf!
Die Domain wird im pi-hole nicht geblockt!
Ich habe dann versucht per Group Management das Problem zu lösen: eine neue Gruppe "OhneFilter" erstellt und unter Clients den Robi erst per Liste ausgewählt und auch per manueller IP eingegeben. Diesem Eintrag dann nur die Gruppe "OhneFilter" zugewiesen, "Default" nicht! Alle AddLists etc sind nur der Gruppe "Default" zugewiesen.
Scheinbar wird aber die Zuweisung des Robi zur Liste ignoriert, den sobald ich in der FRitz!Box den lokalen DNS wieder auf den pi-hole stelle und den Lease des Robi erneuere (bekommt immer die gleiche IP) dann habe ich keine Verbindung mehr per App zum Robi. Am Robi selbst blinkt auch das WLAN-Symbol, was gleichbedeutend mit "finde meine Cloud nicht" ist.
Ich hoffe dass ich nicht zu viel OT-Zeugs geschrieben habe, aber vielleicht kann mir ja einer helfen?

Debug log habe ich hochgeladen, ist aber vermutlich nur für die Admins??
https://tricorder.pi-hole.net/Nu3HUbrJ/

Verwendete pi-hole-Version:
Docker Tag 2024.05.0
Pi-hole v5.18.2
FTL v5.25.2
Web Interface v5.21

Vielen Dank für die Unterstützung!

Ich habe das Gefühl, dass es damit zusammenhängt, wie Sie den Docker-Container für die Verbindung zum Host vom Container aus einrichten. Wären Sie auf irgendeine Weise bereit zu zeigen, wie Ihr Container auf dem Host-Pi-Hole spricht? Ich würde auch raten, den Cloud-Server für den Rasenmäher zu entsperren. Es könnte andere IP-Adressen geben, die sich mit dem Rasenmäher verknüpfen (je nachdem, wie sie in Ihrem Netzwerk kommunizieren und funktionieren sollen (ich weiß nicht, wie drahtlose Rasenmäher funktionieren, da ich noch keinen in die Hände bekommen habe). ).
Weitere Frage: Warum platzieren Sie den Rasenmäher nicht in einem Dummy-Netzwerk/stellen Sie den Mäher in einem VLAN ein und haben Sie Pihole-DNS in diesem VLAN mit dem Mäher?

Ich hoffe, Sie haben einen schönen Freitag.

I have a sneaking feeling that it has to do with how you set up the Docker container for connecting to the host from the container. is there any way you'd be willing to show how you have your Container speaking on the host pi-hole? Another thing I would say is try unblocking the cloud server for the Lawn Mower? There might be other IP addresses that might be associating itself with the lawn mower (depending on how they are speaking on your network and are meant to work (I do not know how wireless lawnmowers work as I have not gotten my hands on one yet)).
Further question why not place the lawnmower on a dummy network/ have the mower on a VLAN and have pihole DNS on that vlan with the mower.

Hope you are having a good Friday. :smiley:

Hallo KoolKyle,
vielen Dank für Deine Antwort!
Den pi-hole habe ich wie folgt aufgebaut:
x=jeweils gleicher Wert
Fritz!Box 7590 V7.5.7 IP 192.168.x.1
Lokaler DNS zeigt auf 192.168.x.3 (pi-hole)
OMV 6.9.15-2 mit fester IP z.B. 192.168.x.9
im OMV ein macvlan für pi-hole eingerichtet --> 192.168.x.3
im OMV Portainer installiert CE V2.19.5
im Portainer:
|IPV4 Subnet - 192.168.x.0/24|IPV4 Gateway - 192.168.x.1|
|IPV4 IP Range - 192.168.x.3/32|IPV4 Excluded IPs|

Wie bereits erwähnt, lief das ganze bisher reibungslos und auch der Robi konnte sich immer mit seiner Cloud verbinden - bis zum 07.05. gegen 02:26 Uhr. Irgendetwas muss also aktualisiert worden sein, was nun dazu führte, dass er die Cloud nicht mehr findet.
Im pi-hole sind unter der IP des Robi keine Adressen, die geblockt werden! Leider kann ich dem Robi auch keine manuellen IP-Einstellungen geben, der kann nur DHCP. VLAN ist auch keine Option, da die Fritz!Box keine VLANs verwalten kann.
Mir bleibt also nur in der Fritz!Box den lokalen DNS auf Standard (also DNS durch die Fritz!Box) zu setzen und damit leider den pi-hole für das gesamte Netz zu deaktivieren, wenn ich den Robi über die App fernsteuern möchte.
Ich verstehe nicht, warum das Group Management hier nicht funktioniert.