Graph / stats not displaying anything

Hi everyone,

My pihole is working fine and blocking ads , however, my graphs are unresponsive and I don't have access to any stats

Here is my debug token that I generated via netcat (pihole -c didn't upload it )


It used to work but just randomly stops

  • FTL service is running

  • I tried pihole -r and also reinstalling -> no success

  • I tried ctr+alt+r on chrome to clear the cache

  • I tried praying to Piholos, the pi-hole god, but he is as
    unresponsive as my graphs...

  • Also < pihole -r > throwed something : FTL Engine not installed

  • Pihole-FTL version : v2.13.2

  • Problem is the same on android, firefox

Same here. Logs and graphs are not showing up , yet they do exist under /var/log

Some here, just updated and still all blank.

I will add myself to the list of affected users.

Debug token, if needed: 3iiws0a8jj

Additional information:
Logs are written to and up-to-date.
dnsmasq works like a charm.
pihole-FTL process is running.

I found that Piholos sometimes takes notice if I sacrifice some tech unto him. For better or ill, of course, comes his gaze. Conveniently enough, he seems to prefer obsolete gadgets; pocket calculators, digital watches, betamax, things like that. And don't believe those nutcase Piholecostals, its not necessary to speak in binary.

1 Like

Note : debug token has been regenerated as I think they expire after 48 hrs


I re-installed a couple of days ago, since even if I updated, when I rebooted it reverted to 1.31. (using a new card)
So new install was doing the same yesterday, but today is back to normal, i.e. graphs are appearing.

Thanks, I've been away from Discourse for a few days and it looks like no one else has tried to tackle your issue.

Your xq7iwx6kjj token only has 4 lines from the query log. Did you upload the correct log (/var/log/pihole_debug.log)?
Try opening the browser dev tools (F12) and see if there's any errors in the console or network requests.

i was also facing the same issue, then i have clear cache and tried it works.

or you can try another browser to verify,