Google Wifi - all ethernet connections show up as coming from router's IP

Expected Behaviour:

I expect the client ip/hostnames listed on the admin website to be the actual host names

Actual Behaviour:

All ethernet devices seem to show up as coming from the router's IP

Debug Token:

I've seen the problems people have had with only their router IP and/or localhost showing up as the IP for all requests and this is maybe similar to that, but not quite. I see names for all wifi devices, but it seems like all ethernet devices come under my router's IP.

Just started with this and I'm having some trouble. My setup is
Modem -> Google Wifi (just one) -> 8 port switch -> several ethernet devices
With a few devices connected to the GWF via wifi

The GWF has:

  • a DHCP reservation for the pihole
  • DNS set to the rpi's reserved IP as primary and google's dns as secondary
  • WAN settings untouched
  • LAN settings: router LAN address/mask default at
  • LAN settings: DHCP Address pool set to start and end at the pihole's reserved IP

The PiHole has:

  • the OS itself has wifi off and is only connected via an ethernet connection
  • Under DNS, Google & OpenDNS set as secondaries with the rpi as a primary (though, it has a "#53" added to the end of the IP that I didn't add?). Set to listen to all interfaces.

Not sure what else you may need to help that isn't already in this message or the debug token, but please let me know if there is any other information I can provide.


Just a word of caution, please read

Please check your clients that are connected through Ethernet if they show that they correctly received the Pi-hole's IP address through DHCP. I suspect that they are still list the router's IP address. The router is then doing the requests for them which causes its IP to be shows as the source.
I do agree that the fact that the WiFi devices are not affected by this is rather bizarre, so, before speculating more, I'd first like to see your response to what the wired (and maybe even the wireless!) devices received network configuration look like.

Thanks for the clarification! I guess I should say that of the two columns under "ipv4" in the upstream dns servers section of the pihole's dns settings, the one on the right is checked for Google. I have "Custom 1 (IPv4)" set originally to my pihole's reserved IP, but it seems to have that #53 added afterwards.

Wait a second, I think I'm understanding whats going on. My ethernet-wired computer is now getting internet after I had disconnected it to see if it would be recognized going on wifi (unfortunately there seems to be some unrelated issue preventing my computer from accessing wifi but thats a whole other story). When I plugged it back in, it was showing up. Now I'm realizing that maybe it's not the wired devices - only real one I could test easily and see traffic for was my laptop. I also realized there is another raspberry pi connected wirelessly that is still showing up as the router's IP, so that breaks that theory.

I thought it was something to do with my laptop and that non-pihole rpi previously having reserved dhcps on the GWF (and I haven't set them up again on the pihole) but I just restarted that rpi so it could get a new connection and unfortunately the problem persists. At this point it's not a huge deal if it didn't get figured out but I would kinda just like to have it figured out so the logs look more how they should and so someone later having a similar issue might find it.

So, on to your question - I don't really know how to do that :confused: The rpi mentioned is actually running Octopi based on Debian, what command could I run to get what you're looking for?

Can you provide a screenshot? Does this mean you set the IP of the Pi-hole as a DNS server on the Pi-hole? This would end up in an infinite loop as the Pi-hole would ask the Pi-hole would ask the Pi-hole would ask the Pi-hole, ...
This should obviously not be done. A healthy setup is to just use any combination of check boxes on the left side, there is no need to specify custom DNS servers for the vast majority of users.
The added #53 is expected, this is the port it tries to connect to (it automatically adds port 53 is you specified none).

The question is how the network settings look like on the other devices in your network: Laptop, wired computer, ...
On Linux devices you can use nmcli device show to get the information we need. On other operating systems, you'll have to ask Mr. Google, I'm solely using Linux myself.

Well now that you say it like that, it does sound pretty stupid. When I was trying to figure this all out and dealing with the GWF making things tricky, I think some screenshot on some tutorial had that Custom 1 pointed at the pihole. I'll remove that.

where *.209 is the ip of the pihole

But in good news, I think this was a classic PEBKAC error. I think somewhere in my wireless rpi I mentioned, I set it to have a static IP of *.9 in addition to setting it on the GWF so even though I removed it from the GWF it's still trying to have that IP - I found the file where it's declared but don't really want to mess with rebooting anything since it's currently running a 3d print. The range of the DHCP on the pihole was set to be a low of 20, which is too high to catch the *.9 so I moved the low to *.8 and I'm now seeing that IP instead of the router's IP on requests.

So the lesson is when moving over be careful with existing static IPs that are setup and pay more attention to the range of DHCP addresses given by the pihole.

Thank you for your patience! Really appreciate the help with this issue. Looking forward to the benefits of my new pihole!