Google Play updates

For everyone here - I noticed that my PiHole was blocking the updates on my Android phones.
To fix it, I had to whitelist this:

android.clients.google.com

I wonder if there is something similar for iPhones?

And for the Motorola phone (G4 Plus) system update this needs to be whitelisted:

appspot-preview.l.google.com

I only have appleid.apple.com, c.apple.com and itunes.apple.com on my whitelist regarding Apple domains. macos, ios, tvos updates, app store and OTA firmware updates just work fine, nothing blocked.

1 Like

We also have a list of commonly whitelisted domains:

2 Likes

I’m scared to edit that :wink: :
"Anybody can edit it to provide useful tips for whitelisting. Editing abuse may result in a ban from the forums! "

You don’t have to be scared. Feel free to add your finding to the list.

1 Like

Hi Everybody,
i have Android-Update Issues in GooglePlayStore. I already whitelistet
clients1.google.com to clients6.google.com
and android.clients.google.com
I also flushed DNS resolver and restarted PiHole, but I still can not update my Apps in the PlayStore. Any hints? What can I do to update my Apps flawlessly again?
Did I missed something? Did I have to restart something else?

I didn’t had this issues when I started with the previous version of PiHole. It started after the last update to v4.2.2.

I use the debian version of Pi Hole in a VM on my QNAP NAS

Thanks for your Help in Advance.
JamFX

Do you see other/further blocked domains (whatever.google.com) in the Query Log of Pi-hole?

Hi Mibre,
thank you for your reply. No, no other domains where red in my QueryLog. None of them is google-Related. Some from my Alexa are red, but all others are green.
By the way: I use:

46.182.19.48#53
and

194.150.168.168#53
as DNS Servers

Hi Guys,
ok, finally I only had to wait some hours. Now it is working. I added:
clients1 . google.com
clients2 . google.com
android.clients.google.com
appspot-preview.l.google.com

So everything is fine for me now.

What can I do to refresh the whitelist faster?

I took me a day to figure out what happened. Already resetted the pihole, and nothing solved the problem. Then I have checked the router, and I saw that the ipv6 connection is dead. Sooooo, I have changed the settings from native ipv6 to 6to4, and now works like charm. So if Android play store is not working suddenly, just check your router, your provider might dropped ipv6 support :slight_smile: