Google fiber leaking ipv6 DNS

The issue I am facing:
Some devices including Android use the Google ipv6 DNS instead of the Pi Hole.

Details about my system:
Google fiber router with a raspberry pi.

What I have changed since installing Pi-hole:
The raspberry pi has the latest update including the latest update for Pi hole. I have also enabled the pi hole as the DHCP server for ipv4 and ipv6. I also fallowed the official instructions for enabling DNS-over-HTTPS.

I have set the Google fiber to use the pi hole as the ipv4 DNS. However there is no way to disable DHCP or IPv6 on the Google fiber router. All ipv4 traffic works correctly however there are times on Android and Amazon fire devices (maybe others as well) that when the request is not met for IPv6 by the Pi hole that it will use the Google IPv6 DNS provided by the Google Fiber router.

Is there a way to setup an iptable firewall (on the Pi hole) to block the ipv6 DNS IP addresses on the network?

Do you need IPv6?

If not, limit your DHCP range to one address, reserve it for the Pihole device and enable Pihole's DHCP server.

You can't disable IPv6 on the Google fiber router or set a range. You can only do that with ipv4 which I'm not having a problem with.

The Pi hole is set as the DHCP server. If you enable or disable IPv6 on the Pi hole DHCP it will default to using IPv6 on the Google fiber then (For some select devices). So if possible I would like to block the Google IPv6 DNS addresses at the firewall on the raspberry pi.

You'd have to block or disable with IPv6 at your router.

Pi-hole is receiving DNS traffic only. All other network traffic is taking the usual route, i.e. passing directly between local clients or leaving/entering your network through your router.

You may also be able to disable IPv6 on a client device, if your device supports doing so.

You could also consider to put a other bridge/firewall/router beween your internal network and the Google box.