Google 2FA issue

I have run into an issue recently that I have been meaning to get corrected. It is probably something very simple I just can't put my finger on it.

My issue is when I try to sign in to any of my Google accounts. I have had 2FA set up on my phone for quite some time and it always worked perfectly. However, maybe two months ago the sign in prompts stopped appearing on my phone when I am connected to my network.

If I add 8.8.8.8 to my phone's DNS list or flip over to cell data, the prompt will appear on my phone. So I am thinking it is something I need to add to my whitelist.

I feel like I have scoured the forum looking for any and all possible Google related addresses to add. None of them seem to be working.

Once I am verified everything(Gmail, Drive, Youtube, etc.) works fine. It is just getting that initial popup prompt to appear.

Here is a list of the addresses I have:

clientsX.google.com (X= 2, 3, 4, and 6)
android.clients.google.com
accounts.google.com
googleapis.l.google.com
ssl.gstatic.com
connectivitycheck.gstatic.com
csi.gstatic.com
connectivitycheck.android.com

If I am missing one, please let me know.

Thanks.

I found the issue. I needed to whitelist

notifications-pa.googleapis.com

Now it works. In case anyone else comes across this issue.

Thanks.

Seems like you are suffering from overblocking, as this wouldn't apply to a default installation:
notifications-pa.googleapis.com isn't blocked by Pi-hole's default blocklists.

You may find out which lists contain that domain via Tools | Query Lists.

I'd be interested to see why this was blocked. It doesn't appear on any public blocklists that I can find:

https://blocklist-tools.developerdan.com/entries/search?q=notifications-pa.googleapis.com

What is the complete output of the following from the Pi terminal:

pihole -q notifications-pa.googleapis.com

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.